summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen Brown <kbrown@cornell.edu>2021-10-31 19:36:04 -0400
committerKen Brown <kbrown@cornell.edu>2021-10-31 19:36:04 -0400
commitc86a3029ec56ef54d6a23e1c5bed0d554c4b0c2b (patch)
treea80fd6751793188d98fa3851099565bffea7e50d /configure.ac
parent96ac51427f01a96d17f597df4b73f5e59794d6e5 (diff)
parent6ba4e3b78c9ade565ebcb9fa0473c798e0bc0a7b (diff)
downloademacs-c86a3029ec56ef54d6a23e1c5bed0d554c4b0c2b.tar.gz
Merge from origin/emacs-28
6ba4e3b78c Drop support for native compilation on 32-bit Cygwin 7e15ee5bc9 ; * doc/emacs/help.texi (Help Mode): Improve indexing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86928c83934..33e7037afe2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -486,6 +486,7 @@ OPTION_DEFAULT_ON([zlib],[don't compile with zlib decompression support])
OPTION_DEFAULT_ON([modules],[don't compile with dynamic modules support])
OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
OPTION_DEFAULT_OFF([native-compilation],[compile with Emacs Lisp native compiler support])
+OPTION_DEFAULT_OFF([cygwin32-native-compilation],[use native compilation on 32-bit Cygwin])
AC_ARG_WITH([file-notification],[AS_HELP_STRING([--with-file-notification=LIB],
[use a file notification library (LIB one of: yes, inotify, kqueue, gfile, w32, no)])],
@@ -3839,6 +3840,16 @@ source on this site:
HAVE_NATIVE_COMP=no
LIBGCCJIT_LIBS=
LIBGCCJIT_CFLAGS=
+if test "$canonical" = i686-pc-cygwin; then
+ if test "${with_cygwin32_native_compilation}" = yes; then
+ with_native_compilation=yes
+ elif test "${with_native_compilation}" != no; then
+ AC_MSG_ERROR([Native compilation is not supported on 32-bit Cygwin.
+If you really want to try it anyway, use the configure option
+'--with-cygwin32-native-compilation'.])
+ fi
+fi
+
if test "${with_native_compilation}" != "no"; then
if test "${HAVE_PDUMPER}" = no; then
AC_MSG_ERROR(['--with-native-compilation' requires '--with-dumping=pdumper'])