summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2007-04-19 18:07:26 +0000
committerChong Yidong <cyd@stupidchicken.com>2007-04-19 18:07:26 +0000
commit465ace28f89e41b1ed284dca2240fd37e25bb53e (patch)
tree217e88a21224c11bff25190b65d075734b99a335 /configure.in
parente45f35a0bb20a0bc076c8f9a9cdcefdbc29c4dc7 (diff)
downloademacs-465ace28f89e41b1ed284dca2240fd37e25bb53e.tar.gz
Signal error if Xaw libs are missing in a Lucid build.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 108fa4f429d..4c64970fe0f 100644
--- a/configure.in
+++ b/configure.in
@@ -2206,7 +2206,7 @@ fi
dnl Do not put whitespace before the #include statements below.
dnl Older compilers (eg sunos4 cc) choke on it.
-if test x"${USE_X_TOOLKIT}" = xmaybe; then
+if test x"${USE_X_TOOLKIT}" = xmaybe || test x"${USE_X_TOOLKIT}" = xLUCID; then
if test x"${HAVE_X11R5}" = xyes; then
AC_MSG_CHECKING(X11 version 5 with Xaw)
AC_CACHE_VAL(emacs_cv_x11_version_5_with_xaw,
@@ -2220,8 +2220,12 @@ if test x"${USE_X_TOOLKIT}" = xmaybe; then
AC_MSG_RESULT([5 or newer, with Xaw; use toolkit by default])
USE_X_TOOLKIT=LUCID
else
- AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
- USE_X_TOOLKIT=none
+ if test x"${USE_X_TOOLKIT}" = xLUCID; then
+ AC_MSG_ERROR([Lucid toolkit requires X11/Xaw include files])
+ else
+ AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
+ USE_X_TOOLKIT=none
+ fi
fi
else
USE_X_TOOLKIT=none