summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>2007-01-03 23:47:04 +0000
committerRichard M. Stallman <rms@gnu.org>2007-01-03 23:47:04 +0000
commit576538836a5a8037e264f05b0f2b9c1960fff0dd (patch)
treefce6110ad83970e26974cec53f47aa2d0f39e239 /configure.in
parentdfc265a31fd11a6d7b0f994959a1cab0909b18dd (diff)
downloademacs-576538836a5a8037e264f05b0f2b9c1960fff0dd.tar.gz
Detect and use fink-installed in intel-based Mac builds; change Apple
Darwin section to support both PowerPC and Intel-based Macs.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 18 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 2e4580ce175..3a75d855423 100644
--- a/configure.in
+++ b/configure.in
@@ -378,6 +378,24 @@ dnl see the `changequote' comment above.
machine=apollo opsys=bsd4-3
;;
+ ## Apple Darwin / Mac OS X
+ *-apple-darwin* )
+ case "${canonical}" in
+ i[3456]86-* ) machine=intel386 ;;
+ powerpc-* ) machine=powermac ;;
+ * ) unported=yes ;;
+ esac
+ opsys=darwin
+ # Define CPP as follows to make autoconf work correctly.
+ CPP="${CC-cc} -E -no-cpp-precomp"
+ # Use fink packages if available.
+ if test -d /sw/include && test -d /sw/lib; then
+ GCC_TEST_OPTIONS="-I/sw/include -L/sw/lib"
+ CPP="${CPP} ${GCC_TEST_OPTIONS}"
+ NON_GCC_TEST_OPTIONS=${GCC_TEST_OPTIONS}
+ fi
+ ;;
+
## AT&T 3b2, 3b5, 3b15, 3b20
we32k-att-sysv* )
machine=att3b opsys=usg5-2-2
@@ -1154,19 +1172,6 @@ dnl see the `changequote' comment above.
machine=f301 opsys=uxpv
;;
- ## Darwin / Mac OS X
- powerpc-apple-darwin* )
- machine=powermac opsys=darwin
- # Define CPP as follows to make autoconf work correctly.
- CPP="${CC-cc} -E -no-cpp-precomp"
- # Use fink packages if available.
- if test -d /sw/include && test -d /sw/lib; then
- GCC_TEST_OPTIONS="-I/sw/include -L/sw/lib"
- CPP="${CPP} ${GCC_TEST_OPTIONS}"
- NON_GCC_TEST_OPTIONS=${GCC_TEST_OPTIONS}
- fi
- ;;
-
## AMD x86-64 Linux-based GNU system
x86_64-*-linux-gnu* )
machine=amdx86-64 opsys=gnu-linux