summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2001-03-20 15:47:08 +0000
committerGerd Moellmann <gerd@gnu.org>2001-03-20 15:47:08 +0000
commit29c1b68e5c0bd4a57ef7dbe7b476b20c1d40d05c (patch)
treef6e77a64310b3b5049c993001df85313bc2305af /configure.in
parent2153fe6e9dbd5a46fcfb9edf4e9aade3e0eb47fe (diff)
downloademacs-29c1b68e5c0bd4a57ef7dbe7b476b20c1d40d05c.tar.gz
(HAVE_XPM): Don't print the result of the check for
XpmReturnAllocPixels if we don't have an xpm.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 460d1b31d06..00d283daac5 100644
--- a/configure.in
+++ b/configure.in
@@ -1811,18 +1811,19 @@ if test "${HAVE_X11}" = "yes"; then
AC_CHECK_HEADER(X11/xpm.h,
AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
if test "${HAVE_XPM}" = "yes"; then
- AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
- AC_EGREP_CPP(no_return_alloc_pixels,
- [#include "X11/xpm.h"
+ AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
+ AC_EGREP_CPP(no_return_alloc_pixels,
+ [#include "X11/xpm.h"
#ifndef XpmReturnAllocPixels
no_return_alloc_pixels
#endif
- ], HAVE_XPM=no, HAVE_XPM=yes)
- fi
- if test "${HAVE_XPM}" = "yes"; then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
+ ], HAVE_XPM=no, HAVE_XPM=yes)
+
+ if test "${HAVE_XPM}" = "yes"; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
fi
fi