summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2007-03-19 01:05:29 +0000
committerChong Yidong <cyd@stupidchicken.com>2007-03-19 01:05:29 +0000
commitae61688f89ef63104eb2b7c2ef0738ecd17d9b9f (patch)
tree048cddf1f3c201a612bbe0051d00c87381831750 /configure.in
parent39e653ead8fb85137f5d5d060ad658150c698486 (diff)
downloademacs-ae61688f89ef63104eb2b7c2ef0738ecd17d9b9f.tar.gz
Don't define KERBEROS, KERBEROS5, or HESIOD if the user specifies
"without".
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e9ffb8d9be8..842002d33a1 100644
--- a/configure.in
+++ b/configure.in
@@ -54,7 +54,9 @@ AC_DEFINE(MAIL_USE_POP))
AH_TEMPLATE(MAIL_USE_POP, [Define to support POP mail retrieval.])dnl
AC_ARG_WITH(kerberos,
[ --with-kerberos support Kerberos-authenticated POP],
-[AC_DEFINE(KERBEROS)])
+[if test "$withval" = yes; then
+ AC_DEFINE(KERBEROS)
+fi])
AH_TEMPLATE(KERBEROS,
[Define to support Kerberos-authenticated POP mail retrieval.])dnl
AC_ARG_WITH(kerberos5,
@@ -64,11 +66,13 @@ AC_ARG_WITH(kerberos5,
with_kerberos=yes
AC_DEFINE(KERBEROS)
fi
-fi
-AC_DEFINE(KERBEROS5, 1, [Define to use Kerberos 5 instead of Kerberos 4.])])
+ AC_DEFINE(KERBEROS5, 1, [Define to use Kerberos 5 instead of Kerberos 4.])
+fi])
AC_ARG_WITH(hesiod,
[ --with-hesiod support Hesiod to get the POP server host],
-[AC_DEFINE(HESIOD, 1, [Define to support using a Hesiod database to find the POP server.])])
+[if test "$withval" = yes; then
+ AC_DEFINE(HESIOD, 1, [Define to support using a Hesiod database to find the POP server.])
+fi])
AC_ARG_WITH(sound,
[ --without-sound don't compile with sound support])