summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAdrian Robert <Adrian.B.Robert@gmail.com>2009-10-16 03:08:41 +0000
committerAdrian Robert <Adrian.B.Robert@gmail.com>2009-10-16 03:08:41 +0000
commitf5b30dc9b6c1470626299bcc0610867a538859c0 (patch)
treede5c3935adbdb3e5e017dd00a02e5fc314375238 /configure.in
parent2640fa86dabd7865ec7770796bf751571a0b5d5c (diff)
downloademacs-f5b30dc9b6c1470626299bcc0610867a538859c0.tar.gz
(NS_HAVE_NSINTEGER): Back out previous change. (*-apple-darwin*): Add x86_64 architecture.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ce18111f8b0..a9e4c54bb5e 100644
--- a/configure.in
+++ b/configure.in
@@ -456,6 +456,7 @@ dnl see the `changequote' comment above.
case "${canonical}" in
i[3456]86-* ) machine=intel386 ;;
powerpc-* ) machine=macppc ;;
+ x86_64-* ) machine=amdx86-64 ;;
* ) unported=yes ;;
esac
opsys=darwin
@@ -1339,6 +1340,14 @@ if test "${with_ns}" != no; then
AC_CHECK_HEADER([AppKit/AppKit.h], [HAVE_NS=yes],
[AC_MSG_ERROR([`--with-ns' was specified, but the include
files are missing or cannot be compiled.])])
+ NS_HAVE_NSINTEGER=yes
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <Foundation/NSObjCRuntime.h>],
+ [NSInteger i;])],
+ ns_have_nsinteger=yes,
+ ns_have_nsinteger=no)
+ if test $ns_have_nsinteger = no; then
+ NS_HAVE_NSINTEGER=no
+ fi
fi
if test "${HAVE_NS}" = yes; then
window_system=nextstep