summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2023-01-03 11:50:57 -0700
committerSean Whitton <spwhitton@spwhitton.name>2023-01-03 11:50:57 -0700
commit6c5027755a9a29100f3f33ded09a384aab04f372 (patch)
treeed9cb1b26e1a1737007cc5faea7fe723516dd036 /debian
parent046e85d42e9da9757027f876ca6ff3e27a32362e (diff)
parent5bf195aace31dacda96651a576c3afaa3fc3f346 (diff)
downloademacs-6c5027755a9a29100f3f33ded09a384aab04f372.tar.gz
Merge branch 'athena/unstable' into athena/bullseye-backports
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/emacs-snapshot.sh5
-rwxr-xr-xdebian/merge-snapshot4
3 files changed, 16 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 74c0d011644..7bd9b470f8a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+emacs-snapshot (29.1~git20230103.1) unstable; urgency=medium
+
+ * Package git snapshot.
+ * d/merge-snapshot: Find merge base with origin/emacs-29, not origin/master.
+ * d/merge-snapshot: Fix matching AC_INIT line in configure.ac.
+ * d/emacs-snapshot.sh: Add comment regarding update-alternatives.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 03 Jan 2023 11:48:45 -0700
+
emacs-snapshot (29.1~git20221203.1~bpo11+1~athena1) bullseye-backports; urgency=medium
* Rebuild for athena apt repository.
diff --git a/debian/emacs-snapshot.sh b/debian/emacs-snapshot.sh
index 12c67a4a44a..7893d16aa12 100644
--- a/debian/emacs-snapshot.sh
+++ b/debian/emacs-snapshot.sh
@@ -1,3 +1,8 @@
+# We install this script rather than using update-alternatives because
+# whatever is providing /usr/bin/emacs is used to bytecompile files
+# for Debian's packaged builds of Emacs, and there could be
+# incompatibilities if emacs-snapshot builds were invoked to do that.
+
if [ "`id -u`" -ne 0 ]; then
PATH=/opt/emacs-snapshot/bin:$PATH
fi
diff --git a/debian/merge-snapshot b/debian/merge-snapshot
index 83629af517c..6e686307c8e 100755
--- a/debian/merge-snapshot
+++ b/debian/merge-snapshot
@@ -13,7 +13,7 @@ my $git = Git::Wrapper->new(getcwd);
($git->rev_parse({ abbrev_ref => 1 }, "HEAD"))[0] eq "athena/unstable"
or $git->checkout("athena/unstable");
-my ($to_merge) = $git->merge_base("melete", "origin/master");
+my ($to_merge) = $git->merge_base("melete", "origin/emacs-29");
chomp(my $prev_version = `dpkg-parsechangelog -SVersion`);
chomp(my $prev_distn = `dpkg-parsechangelog -SDistribution`);
@@ -29,7 +29,7 @@ my $major_version;
open my $fh, "<", catfile $git->dir, "configure.ac";
for (<$fh>) {
$major_version = $1, last
- if /AC_INIT\(\[GNU Emacs\], \[([0-9]+)\.0\.50\],/
+ if /AC_INIT\(\[GNU Emacs\], \[([0-9]+)\.0\.[56]0\],/
}
$major_version or die "couldn't extract devel major version number";