summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2022-10-16 18:00:50 -0700
committerSean Whitton <spwhitton@spwhitton.name>2022-10-16 18:00:50 -0700
commit72abd4bd773bbcfd61b65cf9b2428a0e724f5893 (patch)
treec7c8cb2cf264770a50ed5baac616d081acbfaa0b /debian
parent40d4d3b8e741a1f0ae7fa41013be1347c6ab11b8 (diff)
parenta49fb252ae0781b550dc29578cdd8e4a4de49ca3 (diff)
downloademacs-72abd4bd773bbcfd61b65cf9b2428a0e724f5893.tar.gz
Merge branch 'athena/unstable' into athena/bullseye-backports
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rwxr-xr-xdebian/merge-snapshot13
-rwxr-xr-xdebian/rules4
3 files changed, 22 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index b71ce67ae16..ddb762e01b0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+emacs-snapshot (29.1~git20221015.1) unstable; urgency=medium
+
+ * Package git snapshot.
+ * d/merge-snapshot: Extract major version number from configure.ac.
+ * d/merge-snapshot: Add comment explaining why we use 29.1 not 29.0.50.
+ * d/rules: Use new --with-native-compilation=aot configure option.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sun, 16 Oct 2022 17:59:07 -0700
+
emacs-snapshot (29.1~git20220912.1~bpo11+1~athena1) bullseye-backports; urgency=medium
* Rebuild for athena apt repository.
diff --git a/debian/merge-snapshot b/debian/merge-snapshot
index fe003515ebd..8ee28d69a05 100755
--- a/debian/merge-snapshot
+++ b/debian/merge-snapshot
@@ -5,6 +5,7 @@ use strict;
use warnings;
use Cwd;
+use File::Spec::Functions "catfile";
use Git::Wrapper;
my $git = Git::Wrapper->new(getcwd);
@@ -24,6 +25,14 @@ $new_date =~ /\A([0-9]{4})-([0-9]{2})-([0-9]{2})/
$new_date = $1 . $2 . $3;
my $new_rev = $prev_date eq $new_date ? $prev_rev + 1 : 1;
+my $major_version;
+open my $fh, "<", catfile $git->dir, "configure.ac";
+for (<$fh>) {
+ $major_version = $1, last
+ if /AC_INIT\(\[GNU Emacs\], \[([0-9]+)\.0\.50\],/
+}
+$major_version or die "couldn't extract devel major version number";
+
$git->merge({
message =>
"Merge remote-tracking branch 'origin/master' into athena/unstable"
@@ -31,7 +40,9 @@ $git->merge({
$to_merge
);
-system "dch", "-v29.1~git${new_date}.${new_rev}",
+# We use .1 not .0.50 because that's what's conventional
+# with Debian "~gitYYYYMMDD.N" git snapshot version numbers.
+system "dch", "-v${major_version}.1~git${new_date}.${new_rev}",
$prev_distn eq "UNRELEASED" ? "" : "Package git snapshot.";
$git->add("debian/changelog");
$git->commit({ message => "changelog" });
diff --git a/debian/rules b/debian/rules
index d03b58c15d1..0cb68380924 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,5 @@
#!/usr/bin/make -f
-export NATIVE_FULL_AOT = 1
-
%:
dh $@
@@ -13,7 +11,7 @@ override_dh_autoreconf:
override_dh_auto_configure:
./configure --prefix=/opt/emacs-snapshot \
- --with-native-compilation --with-pgtk
+ --with-pgtk --with-native-compilation=aot
override_dh_shlibdeps:
dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info