summaryrefslogtreecommitdiff
path: root/leim
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2013-11-28 12:31:55 -0800
committerGlenn Morris <rgm@gnu.org>2013-11-28 12:31:55 -0800
commit698c0f24f170025470f3dcda51c11290062d78c4 (patch)
tree43a4439fda330e839ae804f24d3f9267885e4e38 /leim
parentc2a2e7b0b048b74a9b0f362747120245e68ed0e5 (diff)
downloademacs-698c0f24f170025470f3dcda51c11290062d78c4.tar.gz
* leim/leim-ext.el: Change method for getting comments in the output
to one that does not fool lisp/compile-main's no-byte-compile test. * leim/Makefile.in (${leimdir}/leim-list.el): Adapt for this.
Diffstat (limited to 'leim')
-rw-r--r--leim/ChangeLog6
-rw-r--r--leim/Makefile.in2
-rw-r--r--leim/leim-ext.el15
3 files changed, 15 insertions, 8 deletions
diff --git a/leim/ChangeLog b/leim/ChangeLog
index b5099b5a442..31b9c376903 100644
--- a/leim/ChangeLog
+++ b/leim/ChangeLog
@@ -1,3 +1,9 @@
+2013-11-28 Glenn Morris <rgm@gnu.org>
+
+ * Makefile.in (${leimdir}/leim-list.el):
+ * leim-ext.el: Change method for getting comments in the output
+ to one that does not fool lisp/compile-main's no-byte-compile test.
+
2013-11-27 Glenn Morris <rgm@gnu.org>
* Makefile.in (bootstrap-clean): No need to delete .elc,
diff --git a/leim/Makefile.in b/leim/Makefile.in
index 9fe71ae6fe1..4e067db3445 100644
--- a/leim/Makefile.in
+++ b/leim/Makefile.in
@@ -132,7 +132,7 @@ ${leimdir}/leim-list.el: ${TIT_MISC} ${srcdir}/leim-ext.el
rm -f $@
${RUN_EMACS} -l international/quail \
--eval "(update-leim-list-file (unmsys--file-name \"${leimdir}\"))"
- sed -n '/^[^;]/ p' < ${srcdir}/leim-ext.el >> $@
+ sed -n -e '/^[^;]/p' -e 's/;inc/;/p' < ${srcdir}/leim-ext.el >> $@
${leimdir}/ja-dic/ja-dic.el: $(srcdir)/SKK-DIC/SKK-JISYO.L
@$(MKDIR_P) $(leimdir)/ja-dic
diff --git a/leim/leim-ext.el b/leim/leim-ext.el
index b5fc3118862..0f92fd6c645 100644
--- a/leim/leim-ext.el
+++ b/leim/leim-ext.el
@@ -76,16 +76,17 @@
'hangul390-input-method
"Input method: korean-hangul390 (mode line indicator:한390)\n\nHangul 3-Bulsik 390 input method.")
-;; Following lines are indented so that Makefile adds them to output.
+;; Following lines are marked such that Makefile adds them to output.
;; leim-list-header adds "coding: utf-8"; we could move that here,
;; unless others are using that stuff to generate their own leim files.
+;; TODO? Better to add leim-list-footer?
- ;; Local Variables:
- ;; no-byte-compile: t
- ;; version-control: never
- ;; no-update-autoloads: t
- ;; End:
+;;inc Local Variables:
+;;inc no-byte-compile: t
+;;inc version-control: never
+;;inc no-update-autoloads: t
+;;inc End:
- ;;; leim-list.el ends here
+;;;inc leim-list.el ends here
;;; leim-ext.el ends here