summaryrefslogtreecommitdiff
path: root/lib-src
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-03-28 13:58:44 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-03-28 14:08:11 -0700
commit4f41188a6e1eb0ce832bd74907642f30ada344d9 (patch)
treee7416c28af32c57cd06614ea995e10c334ea0aa1 /lib-src
parenta775dca449ca8da2e2619ea608a3849f70fa951e (diff)
downloademacs-4f41188a6e1eb0ce832bd74907642f30ada344d9.tar.gz
Stop using newly-deprecated dosname Gnulib module
Code is supposed to use the filename module now. * admin/merge-gnulib (GNULIB_MODULES): Replace dosname with filename. * lib/dosname.h: Remove this forwarding stub. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate. * lib-src/emacsclient.c, src/fileio.c: Include filename.h instead of dosname.h.
Diffstat (limited to 'lib-src')
-rw-r--r--lib-src/emacsclient.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib-src/emacsclient.c b/lib-src/emacsclient.c
index 204064f1871..380be95222b 100644
--- a/lib-src/emacsclient.c
+++ b/lib-src/emacsclient.c
@@ -80,7 +80,7 @@ char *w32_getenv (const char *);
#include <sys/stat.h>
#include <unistd.h>
-#include <dosname.h>
+#include <filename.h>
#include <intprops.h>
#include <min-max.h>
#include <pathmax.h>