summaryrefslogtreecommitdiff
path: root/lib/_Noreturn.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-02-09 00:44:11 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2020-02-09 00:45:42 -0800
commit5e7bead8eac9a79dfd74452a7bd5199f12ad0c45 (patch)
tree449a49b0635fc2f8d6acb43bcbaabf6621de4015 /lib/_Noreturn.h
parent2645ae1222db1df270276b227e5102884466ecb0 (diff)
downloademacs-5e7bead8eac9a79dfd74452a7bd5199f12ad0c45.tar.gz
Update from Gnulib
This incorporates: 2020-02-08 lchmod: ensure declaration on HP-UX 2020-02-08 fchmodat: fix endless recursion on Cygwin 2020-02-08 Fix compilation errors in a testdir 2020-02-07 fchmodat: AT_SYMLINK_NOFOLLOW fix for non-symlinks 2020-02-04 Port _Noreturn to older Clang 2020-02-03 libc-config: port to Appleā€™s Clang variant * lib/_Noreturn.h, lib/c++defs.h, lib/libc-config.h, lib/sys_stat.in.h: * m4/gnulib-common.m4, m4/sys_stat_h.m4: Copy from Gnulib. * lib/gnulib.mk.in: Regenerate.
Diffstat (limited to 'lib/_Noreturn.h')
-rw-r--r--lib/_Noreturn.h5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/_Noreturn.h b/lib/_Noreturn.h
index 0d4b9c29e02..394ca3c2aa2 100644
--- a/lib/_Noreturn.h
+++ b/lib/_Noreturn.h
@@ -28,7 +28,10 @@
# define _Noreturn [[noreturn]]
# elif ((!defined __cplusplus || defined __clang__) \
&& (201112 <= (defined __STDC_VERSION__ ? __STDC_VERSION__ : 0) \
- || 4 < __GNUC__ + (7 <= __GNUC_MINOR__)))
+ || 4 < __GNUC__ + (7 <= __GNUC_MINOR__) \
+ || (defined __apple_build_version__ \
+ ? 6000000 <= __apple_build_version__ \
+ : 3 < __clang_major__ + (5 <= __clang_minor__))))
/* _Noreturn works as-is. */
# elif 2 < __GNUC__ + (8 <= __GNUC_MINOR__) || 0x5110 <= __SUNPRO_C
# define _Noreturn __attribute__ ((__noreturn__))