summaryrefslogtreecommitdiff
path: root/lib/alloca.in.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2019-03-10 23:03:48 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2019-03-10 23:05:30 -0700
commite2f35443796d423ea5f96a99da425a927327deb2 (patch)
tree2ca4cce0736f937dcc60881686500bb4c752a034 /lib/alloca.in.h
parent89082c823c738b8e3b436e4af1307eefe193eac9 (diff)
downloademacs-e2f35443796d423ea5f96a99da425a927327deb2.tar.gz
Update from Gnulib
This incorporates: 2019-03-10 alloca-opt: Fix conflict mingw's new <alloca.h> file 2019-03-03 getloadavg: Write NULL for the null pointer Reported by Michal Privoznik <mprivozn@redhat.com>. * lib/getloadavg.c (getloadavg): Write NULL instead of 0. * build-aux/config.guess, build-aux/move-if-change: * doc/misc/texinfo.tex, lib/alloca.in.h, lib/getloadavg.c: * m4/alloca.m4: Copy from Gnulib. * lib/gnulib.mk.in: Regenerate.
Diffstat (limited to 'lib/alloca.in.h')
-rw-r--r--lib/alloca.in.h6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/alloca.in.h b/lib/alloca.in.h
index ec81e119a0f..a581d58f834 100644
--- a/lib/alloca.in.h
+++ b/lib/alloca.in.h
@@ -36,6 +36,12 @@
#ifndef alloca
# ifdef __GNUC__
+ /* Some version of mingw have an <alloca.h> that causes trouble when
+ included after 'alloca' gets defined as a macro. As a workaround, include
+ this <alloca.h> first and define 'alloca' as a macro afterwards. */
+# if (defined _WIN32 && ! defined __CYGWIN__) && @HAVE_ALLOCA_H@
+# include_next <alloca.h>
+# endif
# define alloca __builtin_alloca
# elif defined _AIX
# define alloca __alloca