summaryrefslogtreecommitdiff
path: root/lib/arg-nonnull.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-03-14 13:44:11 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-03-14 14:50:02 -0700
commitfac0bb9cf76072941ae9dc9c7019929eb1a0f1dd (patch)
tree1b9618b5eea568e8230b4348af3df1084bd63e67 /lib/arg-nonnull.h
parent5a64d78854998c2ed6d9b8de1b593d8462b8fa39 (diff)
downloademacs-fac0bb9cf76072941ae9dc9c7019929eb1a0f1dd.tar.gz
Merge from gnulib
This incorporates: 2017-03-14 snippets: move unadjusted snippet sources to lib 2017-03-14 gnulib-tool: fix typo in comment output 2017-03-14 snippets: work around GNU Make 3.82 VPATH 2017-03-13 gnulib-tool: minor --gnu-make fixups 2017-03-12 gnulib-tool: new option --gnu-make * .gitignore: Remove lib/arg-nonnull.h, lib/c++defs.h, lib/warn-on-use.h. Change exception from build-aux/snippet/_Noreturn.h to lib/_Noreturn.h. * admin/authors.el (authors-renamed-files-regexps): * admin/notes/copyright, make-dist: The snippet files moved from build-aux/snippet to lib. * lib/_Noreturn.h: Rename from build-aux/snippet/_Noreturn.h. * lib/arg-nonnull.h: Rename from build-aux/snippet/arg-nonnull.h. * lib/c++defs.h: Rename from build-aux/snippet/c++defs.h. * lib/gnulib.mk, m4/gnulib-comp.m4: Regenerate. * lib/warn-on-use.h: Rename from build-aux/snippet/warn-on-use.h.
Diffstat (limited to 'lib/arg-nonnull.h')
-rw-r--r--lib/arg-nonnull.h26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/arg-nonnull.h b/lib/arg-nonnull.h
new file mode 100644
index 00000000000..1e62cc89827
--- /dev/null
+++ b/lib/arg-nonnull.h
@@ -0,0 +1,26 @@
+/* A C macro for declaring that specific arguments must not be NULL.
+ Copyright (C) 2009-2017 Free Software Foundation, Inc.
+
+ This program is free software: you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published
+ by the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
+
+/* _GL_ARG_NONNULL((n,...,m)) tells the compiler and static analyzer tools
+ that the values passed as arguments n, ..., m must be non-NULL pointers.
+ n = 1 stands for the first argument, n = 2 for the second argument etc. */
+#ifndef _GL_ARG_NONNULL
+# if (__GNUC__ == 3 && __GNUC_MINOR__ >= 3) || __GNUC__ > 3
+# define _GL_ARG_NONNULL(params) __attribute__ ((__nonnull__ params))
+# else
+# define _GL_ARG_NONNULL(params)
+# endif
+#endif