summaryrefslogtreecommitdiff
path: root/lib/ftoastr.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-09-15 11:50:23 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2016-09-15 15:55:30 -0700
commit8f4b6a20bfec96086845b2f7161e121b1e41b4ad (patch)
treee8c4a85626437b0f77ed0a7b575e7627d45dce9e /lib/ftoastr.h
parent3c586e182c0694896dda670f5fc663b46c9bac63 (diff)
downloademacs-8f4b6a20bfec96086845b2f7161e121b1e41b4ad.tar.gz
Update from gnulib
This incorporates: 2016-09-15 stdint: support new _WIDTH macros 2016-09-15 limits-h: new module 2016-09-15 sys_types: avoid glibc 2.25 warnings about major() 2016-09-15 extensions: port to more ISO C TSes 2016-09-13 intprops: new macro TYPE_WIDTH 2016-09-13 extensions: port to recent ISO C TRs * .gitignore: Add lib/limits.h. * doc/misc/texinfo.tex, lib/ftoastr.h, lib/intprops.h: * lib/stdint.in.h, m4/extensions.m4, m4/stdint.m4, m4/stdio_h.m4: * m4/sys_types_h.m4: Copy from gnulib. * lib/gnulib.mk, m4/gnulib-comp.m4: Regenerate. * lib/limits.in.h, m4/limits-h.m4: New files, copie from gnulib. * nt/gnulib.mk: Merge changes from lib/gnulib.mk.
Diffstat (limited to 'lib/ftoastr.h')
-rw-r--r--lib/ftoastr.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/ftoastr.h b/lib/ftoastr.h
index 9207809e9fb..94816d1a56b 100644
--- a/lib/ftoastr.h
+++ b/lib/ftoastr.h
@@ -88,7 +88,7 @@ enum
# elif FLT_RADIX <= 16 /* IBM hex floating point has FLT_RADIX == 16. */
# define _GL_FLOAT_DIG_BITS_BOUND 4
# else /* no machine is this bad, but let's be complete */
-# define _GL_FLOAT_DIG_BITS_BOUND (CHAR_BIT * (int) sizeof (int) - 1)
+# define _GL_FLOAT_DIG_BITS_BOUND ((int) TYPE_WIDTH (int) - 1)
# endif
/* An upper bound on the number of decimal digits needed to represent