summaryrefslogtreecommitdiff
path: root/lib/intprops.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-12-18 15:41:45 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2015-12-18 15:42:12 -0800
commit73b3beb56dd573a77fd7b103014f2d74674f2e23 (patch)
tree27a552222062dbf966f4442ed5e1eec77ba53d4f /lib/intprops.h
parent81e523fc4d3dcb0cf59a69f45786d2691f982695 (diff)
downloademacs-73b3beb56dd573a77fd7b103014f2d74674f2e23.tar.gz
Merge from gnulib
This mostly commentary fixes. * doc/misc/texinfo.tex, lib/intprops.h: Copy from gnulib. * lib/gnulib.mk: Regenerate with new gnulib-tool.
Diffstat (limited to 'lib/intprops.h')
-rw-r--r--lib/intprops.h7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/intprops.h b/lib/intprops.h
index 8fff86d4371..ecafaf70e15 100644
--- a/lib/intprops.h
+++ b/lib/intprops.h
@@ -272,9 +272,10 @@
Example usage, assuming A and B are long int:
- long int result = INT_MULTIPLY_WRAPV (a, b);
- printf ("result is %ld (%s)\n", result,
- INT_MULTIPLY_OVERFLOW (a, b) ? "after overflow" : "no overflow");
+ if (INT_MULTIPLY_OVERFLOW (a, b))
+ printf ("result would overflow\n");
+ else
+ printf ("result is %ld (no overflow)\n", a * b);
Example usage with WRAPV flavor: