summaryrefslogtreecommitdiff
path: root/lib/limits.in.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-03-19 13:07:03 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-03-19 13:09:31 -0700
commitfa90c5e86e2b11e89c6a1d709e25003a60656f0d (patch)
tree278612addfeefebe9318afd6d052f54accacb108 /lib/limits.in.h
parent20ccaa63dbf20c0a64e0df360800ee61423252b7 (diff)
downloademacs-fa90c5e86e2b11e89c6a1d709e25003a60656f0d.tar.gz
Merge from gnulib
This gets Emacs working again with HP-UX Itanium cc. It incorporates: 2017-03-19 stdalign: tweak version# and test for HP-UX IA64 2017-03-18 stdalign: restore previous behavior for HP-UX IA64 2017-03-17 stat-time, timespec: Support header files in C++ mode 2017-03-17 stdalign: Make it work with HP-UX cc 2017-03-17 flexmember: try to detect HP-UX 11.31 cc bug 2017-03-16 stdint: Fix test compilation failure with HP-UX 11 cc. 2017-03-14 gnulib-tool: don't produce tests with only snippets 2017-03-14 limits-h: Make it work with HP-UX cc. * etc/PROBLEMS: Remove now-obsolete entry for HP-UX 11.31. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate. * lib/limits.in.h, lib/stat-time.h, lib/stdalign.in.h: * lib/stdint.in.h, lib/timespec.h, m4/flexmember.m4, m4/stdalign.m4: Copy from gnulib.
Diffstat (limited to 'lib/limits.in.h')
-rw-r--r--lib/limits.in.h11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/limits.in.h b/lib/limits.in.h
index a7e307f5c66..08d3c328c4a 100644
--- a/lib/limits.in.h
+++ b/lib/limits.in.h
@@ -28,6 +28,17 @@
#ifndef _@GUARD_PREFIX@_LIMITS_H
#define _@GUARD_PREFIX@_LIMITS_H
+/* For HP-UX 11.31. */
+#if defined LONG_LONG_MIN && !defined LLONG_MIN
+# define LLONG_MIN LONG_LONG_MIN
+#endif
+#if defined LONG_LONG_MAX && !defined LLONG_MAX
+# define LLONG_MAX LONG_LONG_MAX
+#endif
+#if defined ULONG_LONG_MAX && !defined ULLONG_MAX
+# define ULLONG_MAX ULONG_LONG_MAX
+#endif
+
/* The number of usable bits in an unsigned or signed integer type
with minimum value MIN and maximum value MAX, as an int expression
suitable in #if. Cover all known practical hosts. This