summaryrefslogtreecommitdiff
path: root/lib/sha256.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-04-06 16:29:36 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-04-06 16:30:09 -0700
commit022755953fc63ef70b72576e14e94324d055ef60 (patch)
tree47ea3e6fb2396a41f413badaf203d698543d68c3 /lib/sha256.h
parent451a0c8b6955006f5aaa8b660a9e0b935b4fa095 (diff)
downloademacs-022755953fc63ef70b72576e14e94324d055ef60.tar.gz
Merge from gnulib
This merges some getopt fixes from Zack Weinberg, and affects only non-GNUish platforms. It incorporates: 2017-04-06 getopt-gnu: omit some duplicate code 2017-04-06 getopt-posix: use angle-bracket include 2017-04-06 getopt: annotate files with relationship to glibc 2017-04-06 getopt: split up getopt.in.h and eliminate __need_getopt 2017-04-06 getopt: better handling of ambiguous options 2017-04-06 getopt: refactor long-option handling 2017-04-06 getopt: tidy up _getopt_initialize a bit 2017-04-06 getopt: merge from glibc: repetition reduction 2017-04-06 getopt: clean up error reporting 2017-04-06 getopt: fix fencepost error in ambiguous-W-option handling 2017-04-06 getopt: clean up getopt.c and getopt1.c file headers 2017-04-06 getopt: harmonize comments with glibc 2017-04-06 getopt: remove USE_NONOPTION_FLAGS 2017-04-06 getopt: tabify, in preparation for merge with glibc 2017-04-06 md5, sha1, sha256, sha512: Add comments re correctness * build-aux/config.sub, doc/misc/texinfo.tex, lib/getopt.c: * lib/getopt.in.h, lib/getopt1.c, lib/getopt_int.h, lib/md5.c: * lib/md5.h, lib/sha1.c, lib/sha1.h, lib/sha256.c, lib/sha256.h: * lib/sha512.c, lib/sha512.h, lib/unistd.in.h, m4/getopt.m4: Copy from gnulib. * lib/getopt_cdefs.in.h, lib/getopt_core.h, lib/getopt_ext.h: * lib/getopt_pfx_core.h, lib/getopt_pfx_ext.h: New files, taken from gnulib. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate.
Diffstat (limited to 'lib/sha256.h')
-rw-r--r--lib/sha256.h4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sha256.h b/lib/sha256.h
index ffb91fa47ef..348b76ef265 100644
--- a/lib/sha256.h
+++ b/lib/sha256.h
@@ -44,8 +44,8 @@ struct sha256_ctx
uint32_t state[8];
uint32_t total[2];
- size_t buflen;
- uint32_t buffer[32];
+ size_t buflen; /* ≥ 0, ≤ 128 */
+ uint32_t buffer[32]; /* 128 bytes; the first buflen bytes are in use */
};
/* Initialize structure containing state of computation. */