summaryrefslogtreecommitdiff
path: root/lib/string.in.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-08-21 12:19:18 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-08-21 12:22:04 -0700
commit3e10174fb65f4eb601b1921271bdcf10c933b879 (patch)
tree4a0948c61c187fc1f9bbd6b73a9f7957c12b74f4 /lib/string.in.h
parent348686b3f318195f4d341206744b8e98470c90f4 (diff)
downloademacs-3e10174fb65f4eb601b1921271bdcf10c933b879.tar.gz
Update from Gnulib
This incorporates: 2020-08-20 sigabbrev_np: New module 2020-08-20 stdalign: Fix 32-bit test failures clang versions < 8 2020-08-17 careadlinkat: speedup for GCC 10 with GCC_LINT 2020-08-17 Assume autoconf >= 2.64 * build-aux/config.guess, build-aux/config.sub, lib/careadlinkat.c: * lib/stdalign.in.h, lib/string.in.h, m4/std-gnu11.m4, m4/string_h.m4: Copy from Gnulib. * lib/gnulib.mk.in: Regenerate.
Diffstat (limited to 'lib/string.in.h')
-rw-r--r--lib/string.in.h15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/string.in.h b/lib/string.in.h
index 7d83668f6ec..5134e11289d 100644
--- a/lib/string.in.h
+++ b/lib/string.in.h
@@ -1045,6 +1045,21 @@ _GL_WARN_ON_USE (strerror_r, "strerror_r is unportable - "
# endif
#endif
+/* Return an abbreviation string for the signal number SIG. */
+#if @GNULIB_SIGABBREV_NP@
+# if ! @HAVE_SIGABBREV_NP@
+_GL_FUNCDECL_SYS (sigabbrev_np, const char *, (int sig));
+# endif
+_GL_CXXALIAS_SYS (sigabbrev_np, const char *, (int sig));
+_GL_CXXALIASWARN (sigabbrev_np);
+#elif defined GNULIB_POSIXCHECK
+# undef sigabbrev_np
+# if HAVE_RAW_DECL_SIGABBREV_NP
+_GL_WARN_ON_USE (sigabbrev_np, "sigabbrev_np is unportable - "
+ "use gnulib module sigabbrev_np for portability");
+# endif
+#endif
+
#if @GNULIB_STRSIGNAL@
# if @REPLACE_STRSIGNAL@
# if !(defined __cplusplus && defined GNULIB_NAMESPACE)