summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-01-13 16:25:28 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2020-01-13 16:27:02 -0800
commit4fc0bc96787252b1b3e14a7f747ef556273b5979 (patch)
tree4df0bfb717a271480089be4c3ccc7d1cd35e8b47 /lib
parent0abda558bc547991cddd9667be722eaeb428dca8 (diff)
downloademacs-4fc0bc96787252b1b3e14a7f747ef556273b5979.tar.gz
Update from gnulib
This incorporates: 2020-01-10 fix major regression from 2020-01-04 2020-01-05 tests: avoid GCC over-optimization 2020-01-04 fix AC_CHECK_DECL so it deactivates clang's built-ins 2020-01-03 getopt-posix: fix compilation failure in testdirs 2020-01-03 doc: mention the 64-bit inode number problem 2020-01-02 wchar: make the HP-UX workaround work on HP-UX 11.31 * build-aux/config.guess, build-aux/config.sub, lib/inttypes.in.h: * lib/stdlib.in.h, lib/unistd.in.h, m4/00gnulib.m4, m4/largefile.m4: * m4/unistd_h.m4: Copy from Gnulib * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate.
Diffstat (limited to 'lib')
-rw-r--r--lib/gnulib.mk.in2
-rw-r--r--lib/inttypes.in.h2
-rw-r--r--lib/stdlib.in.h7
-rw-r--r--lib/unistd.in.h2
4 files changed, 12 insertions, 1 deletions
diff --git a/lib/gnulib.mk.in b/lib/gnulib.mk.in
index 951e5b1a652..ed80f88a874 100644
--- a/lib/gnulib.mk.in
+++ b/lib/gnulib.mk.in
@@ -316,6 +316,7 @@ GNULIB_GETLINE = @GNULIB_GETLINE@
GNULIB_GETLOADAVG = @GNULIB_GETLOADAVG@
GNULIB_GETLOGIN = @GNULIB_GETLOGIN@
GNULIB_GETLOGIN_R = @GNULIB_GETLOGIN_R@
+GNULIB_GETOPT_POSIX = @GNULIB_GETOPT_POSIX@
GNULIB_GETPAGESIZE = @GNULIB_GETPAGESIZE@
GNULIB_GETPASS = @GNULIB_GETPASS@
GNULIB_GETSUBOPT = @GNULIB_GETSUBOPT@
@@ -3210,6 +3211,7 @@ unistd.h: unistd.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H
-e 's/@''GNULIB_GETHOSTNAME''@/$(GNULIB_GETHOSTNAME)/g' \
-e 's/@''GNULIB_GETLOGIN''@/$(GNULIB_GETLOGIN)/g' \
-e 's/@''GNULIB_GETLOGIN_R''@/$(GNULIB_GETLOGIN_R)/g' \
+ -e 's/@''GNULIB_GETOPT_POSIX''@/$(GNULIB_GETOPT_POSIX)/g' \
-e 's/@''GNULIB_GETPAGESIZE''@/$(GNULIB_GETPAGESIZE)/g' \
-e 's/@''GNULIB_GETPASS''@/$(GNULIB_GETPASS)/g' \
-e 's/@''GNULIB_GETUSERSHELL''@/$(GNULIB_GETUSERSHELL)/g' \
diff --git a/lib/inttypes.in.h b/lib/inttypes.in.h
index 5184e266f27..d6efc7eeeef 100644
--- a/lib/inttypes.in.h
+++ b/lib/inttypes.in.h
@@ -38,6 +38,8 @@
# endif
# @INCLUDE_NEXT@ @NEXT_INTTYPES_H@
+
+# define _GL_FINISHED_INCLUDING_SYSTEM_INTTYPES_H
# endif
#endif
diff --git a/lib/stdlib.in.h b/lib/stdlib.in.h
index e088959b285..49bbf6fccfb 100644
--- a/lib/stdlib.in.h
+++ b/lib/stdlib.in.h
@@ -201,6 +201,10 @@ _GL_FUNCDECL_SYS (canonicalize_file_name, char *, (const char *name)
# endif
_GL_CXXALIAS_SYS (canonicalize_file_name, char *, (const char *name));
# endif
+# ifndef GNULIB_defined_canonicalize_file_name
+# define GNULIB_defined_canonicalize_file_name \
+ (!@HAVE_CANONICALIZE_FILE_NAME@ || @REPLACE_CANONICALIZE_FILE_NAME@)
+# endif
_GL_CXXALIASWARN (canonicalize_file_name);
#elif defined GNULIB_POSIXCHECK
# undef canonicalize_file_name
@@ -516,6 +520,9 @@ _GL_FUNCDECL_SYS (ptsname_r, int, (int fd, char *buf, size_t len));
# endif
_GL_CXXALIAS_SYS (ptsname_r, int, (int fd, char *buf, size_t len));
# endif
+# ifndef GNULIB_defined_ptsname_r
+# define GNULIB_defined_ptsname_r (!@HAVE_PTSNAME_R@ || @REPLACE_PTSNAME_R@)
+# endif
_GL_CXXALIASWARN (ptsname_r);
#elif defined GNULIB_POSIXCHECK
# undef ptsname_r
diff --git a/lib/unistd.in.h b/lib/unistd.in.h
index 7909416f366..d6176adc00d 100644
--- a/lib/unistd.in.h
+++ b/lib/unistd.in.h
@@ -141,7 +141,7 @@
/* Get getopt(), optarg, optind, opterr, optopt. */
-#if @GNULIB_UNISTD_H_GETOPT@ && !defined _GL_SYSTEM_GETOPT
+#if @GNULIB_GETOPT_POSIX@ && @GNULIB_UNISTD_H_GETOPT@ && !defined _GL_SYSTEM_GETOPT
# include <getopt-cdefs.h>
# include <getopt-pfx-core.h>
#endif