summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-12-25 19:16:27 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2020-12-25 19:17:04 -0800
commit60bfa84e41449020d1122a1d18b7c11cb73211f3 (patch)
tree22e2a3fc2df1a819aeb66b9beafade3a5cb9f996 /lib
parenta63855cd21aefee993b622241993043a31894c0c (diff)
downloademacs-60bfa84e41449020d1122a1d18b7c11cb73211f3.tar.gz
Fix issues with lib/malloc out-of-dir builds
Problem reported by Mattias EngdegÄrd in: https://lists.gnu.org/r/emacs-devel/2020-12/msg01626.html * configure.ac: If the scratch_buffer module is enabled, create lib/malloc and (if doing dependencies) lib/deps/malloc. * lib/Makefile.in (DEPFLAGS) [AUTO_DEPEND]: No longer any need to squash lib dependencies into a single directory. (clean): Also remove */*.o and $(DEPDIR)/*/*.d, to clean out malloc/*.o and deps/malloc/*.d. Just remove *.d files in dependencies so that rm does not complain about not being able to remove deps/malloc. (extraclean): Also remove malloc, if it is empty.
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/Makefile.in b/lib/Makefile.in
index a280b7a3311..e6b1ae6a9ab 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -67,7 +67,7 @@ endif
DEPDIR = deps
ifeq ($(AUTO_DEPEND),yes)
- DEPFLAGS = -MMD -MF $(DEPDIR)/$(*F).d -MP
+ DEPFLAGS = -MMD -MF $(DEPDIR)/$*.d -MP
-include $(ALLOBJS:%.o=$(DEPDIR)/%.d)
else
DEPFLAGS =
@@ -118,7 +118,7 @@ TAGS: $(ETAGS) $(tagsfiles)
.PHONY: $(ETAGS) tags
clean:
- rm -f ./*.[ao] ./*-t \#* $(DEPDIR)/*
+ rm -f ./*.[ao] ./*/*.o ./*-t \#* $(DEPDIR)/*.d $(DEPDIR)/*/*.d
mostlyclean: clean
rm -f $(filter-out %-t,$(MOSTLYCLEANFILES))
distclean bootstrap-clean: mostlyclean
@@ -127,7 +127,7 @@ distclean bootstrap-clean: mostlyclean
maintainer-clean: distclean
rm -f TAGS gnulib.mk
extraclean: distclean
- -rmdir sys 2>/dev/null
+ -rmdir malloc sys 2>/dev/null
.PHONY: mostlyclean clean distclean bootstrap-clean maintainer-clean