summaryrefslogtreecommitdiff
path: root/lisp/Makefile.in
diff options
context:
space:
mode:
authorStefan Monnier <monnier@iro.umontreal.ca>2018-12-10 10:06:34 -0500
committerStefan Monnier <monnier@iro.umontreal.ca>2018-12-10 10:06:34 -0500
commit063d8c02c2bd3010156a9da040ec6bb0ad4be5ac (patch)
treede99178258924571aa188ab1999489bdb6ff386c /lisp/Makefile.in
parent48d7720993283a3387807fa5582bb10b1636bba5 (diff)
downloademacs-063d8c02c2bd3010156a9da040ec6bb0ad4be5ac.tar.gz
* lisp/Makefile.in (compile-main): Use a more selective regexp.
Diffstat (limited to 'lisp/Makefile.in')
-rw-r--r--lisp/Makefile.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/lisp/Makefile.in b/lisp/Makefile.in
index c4475982981..32f2c1d28a0 100644
--- a/lisp/Makefile.in
+++ b/lisp/Makefile.in
@@ -321,14 +321,16 @@ compile-targets: $(TARGETS)
# Compile all the Elisp files that need it. Beware: it approximates
# 'no-byte-compile', so watch out for false-positives!
compile-main: gen-lisp compile-clean
- @(cd $(lisp) && \
+ @(cd $(lisp) && \
els=`echo "${SUBDIRS_REL} " | sed -e 's|/\./|/|g' -e 's|/\. | |g' -e 's| |/*.el |g'`; \
- for el in ${MAIN_FIRST} $$els; do \
- test -f $$el || continue; \
- test ! -f $${el}c && GREP_OPTIONS= grep '^;.*no-byte-compile: t' $$el > /dev/null && continue; \
- echo "$${el}c"; \
- done | xargs $(XARGS_LIMIT) echo) | \
- while read chunk; do \
+ for el in ${MAIN_FIRST} $$els; do \
+ test -f $$el || continue; \
+ test ! -f $${el}c && \
+ GREP_OPTIONS= grep '^;.*[^a-zA-Z]no-byte-compile: *t' $$el > /dev/null && \
+ continue; \
+ echo "$${el}c"; \
+ done | xargs $(XARGS_LIMIT) echo) | \
+ while read chunk; do \
$(MAKE) compile-targets TARGETS="$$chunk"; \
done