summaryrefslogtreecommitdiff
path: root/lisp/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-03-23 00:07:14 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2016-03-23 00:08:21 -0700
commitc0165ea4d6ecf81db6728782c7322c311ee0a783 (patch)
tree8a2ff49ab30a461068d7b3db5d544f3e64ea6072 /lisp/Makefile.in
parent1e5327c7c7c3b96da032cfdf60146cf3121097bf (diff)
downloademacs-c0165ea4d6ecf81db6728782c7322c311ee0a783.tar.gz
Resurrect GNUS-NEWS autogeneration
* doc/misc/gnus-coding.texi (Gnus Maintenance Guide): Update GNUS-NEWS section to match current file locations and procedure. * etc/GNUS-NEWS: Regenerate by using new procedure. * lisp/Makefile.in (update-gnus-news): New rule, containing a procedure for building GNUS-NEWS. The old procedure got lost somehow when Gnus was merged into Emacs.
Diffstat (limited to 'lisp/Makefile.in')
-rw-r--r--lisp/Makefile.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/lisp/Makefile.in b/lisp/Makefile.in
index 24400a94d6a..f33dd011eda 100644
--- a/lisp/Makefile.in
+++ b/lisp/Makefile.in
@@ -194,7 +194,7 @@ update-subdirs:
$(srcdir)/../build-aux/update-subdirs $$file; \
done;
-.PHONY: updates repo-update update-authors
+.PHONY: updates repo-update update-authors update-gnus-news
# Some modes of make-dist use this.
updates: update-subdirs autoloads finder-data custom-deps
@@ -207,12 +207,16 @@ updates: update-subdirs autoloads finder-data custom-deps
# this directory's autoloads rule.
repo-update: compile finder-data custom-deps
-# Update the AUTHORS file.
+# Update etc/AUTHORS and etc/GNUS-NEWS.
update-authors:
$(emacs) -L "$(top_srcdir)/admin" -l authors \
-f batch-update-authors "$(top_srcdir)/etc/AUTHORS" "$(top_srcdir)"
+update-gnus-news:
+ $(emacs) -L "$(top_srcdir)/doc/misc" -l gnus-news -f batch-gnus-news \
+ "$(top_srcdir)/doc/misc/gnus-news.texi" \
+ "$(top_srcdir)/etc/GNUS-NEWS"
ETAGS = ../lib-src/etags