summaryrefslogtreecommitdiff
path: root/lisp/uniquify.el
diff options
context:
space:
mode:
authorJuanma Barranquero <lekktu@gmail.com>2008-02-14 14:32:44 +0000
committerJuanma Barranquero <lekktu@gmail.com>2008-02-14 14:32:44 +0000
commit20c4d633d37bfe4f7ad1295d9dc09e78b4936bb9 (patch)
tree8408d43492bf4c0db25ca9c75305d34301ee0521 /lisp/uniquify.el
parentb270d6afc02794c82ea320be8d49acd02d8462d2 (diff)
downloademacs-20c4d633d37bfe4f7ad1295d9dc09e78b4936bb9.tar.gz
(uniquify-buffer-base-name): New function.
Suggested by Stefan Monnier <monnier@iro.umontreal.ca>.
Diffstat (limited to 'lisp/uniquify.el')
-rw-r--r--lisp/uniquify.el11
1 files changed, 9 insertions, 2 deletions
diff --git a/lisp/uniquify.el b/lisp/uniquify.el
index da549301580..802f18c3753 100644
--- a/lisp/uniquify.el
+++ b/lisp/uniquify.el
@@ -28,7 +28,7 @@
;;; Commentary:
;; Emacs's standard method for making buffer names unique adds <2>, <3>,
-;; etc.. to the end of (all but one of) the buffers. This file replaces
+;; etc. to the end of (all but one of) the buffers. This file replaces
;; that behavior, for buffers visiting files and dired buffers, with a
;; uniquification that adds parts of the file name until the buffer names
;; are unique. For instance, buffers visiting /u/mernst/tmp/Makefile and
@@ -191,6 +191,13 @@ It actually holds the list of `uniquify-item's corresponding to the conflict.")
(make-variable-buffer-local 'uniquify-managed)
(put 'uniquify-managed 'permanent-local t)
+;; Used in desktop.el to save the non-uniquified buffer name
+(defun uniquify-buffer-base-name ()
+ "Return the base name of the current buffer.
+Return nil if the buffer is not managed by uniquify."
+ (and uniquify-managed
+ (uniquify-item-base (car uniquify-managed))))
+
;;; Main entry point.
(defun uniquify-rationalize-file-buffer-names (base dirname newbuf)
@@ -491,7 +498,7 @@ For use on `kill-buffer-hook'."
(dolist (buf buffers)
(set-buffer (car buf))
(rename-buffer (cdr buf) t))))
- ;; continue standard uploading
+ ;; continue standard unloading
nil)
(provide 'uniquify)