summaryrefslogtreecommitdiff
path: root/lwlib/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-09-03 23:45:44 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2013-09-03 23:45:44 -0700
commit224e313d3bed309a304683c83afe58752cb97e1c (patch)
tree952d4a791e20e1b917b9ca8c3610bfaaecfd64f2 /lwlib/Makefile.in
parent6d6ed1af817d98f7e78a8be10f5fda14a41e18f6 (diff)
downloademacs-224e313d3bed309a304683c83afe58752cb97e1c.tar.gz
Makefile improvements.
* Makefile.in (lib): Depend on am--refresh, to avoid a race. (src): Remove duplicate dependency on FRC. Invoke just one submake, not two. Avoid the need for 'pwd'. * lwlib/Makefile.in (all): Put this first. Don't use double-colon rules, as they are not portable according to POSIX. Mark as phony. * oldXMenu/Makefile.in (all, tags): Don't use double-colon rules, as they are not portable according to POSIX. Mark as phony. * src/Makefile.in (config.status): Don't use double-colon rules, as they are not portable according to POSIX. Fix shell typo with `; I guess this rule has never been tested? (VCSWITNESS): New macro, to override any environment var.
Diffstat (limited to 'lwlib/Makefile.in')
-rw-r--r--lwlib/Makefile.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/lwlib/Makefile.in b/lwlib/Makefile.in
index f228221c45d..40f4a405e97 100644
--- a/lwlib/Makefile.in
+++ b/lwlib/Makefile.in
@@ -59,11 +59,12 @@ ALL_CFLAGS= $(C_SWITCH_SYSTEM) $(C_SWITCH_X_SITE) \
-Demacs -I../src \
-I$(srcdir) -I$(srcdir)/../src -I../lib -I$(srcdir)/../lib
+all: liblw.a
+.PHONY: all
+
.c.o:
$(CC) -c $(CPPFLAGS) $(ALL_CFLAGS) $<
-all:: liblw.a
-
liblw.a: $(OBJS)
rm -f $@
$(AR) $(ARFLAGS) $@ $(OBJS)