summaryrefslogtreecommitdiff
path: root/m4/libgmp.m4
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-08-06 15:24:47 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-08-06 15:25:30 -0700
commit33b293b41b2cc64aa085bad9051507922434ceda (patch)
tree298002879802151ae9c9dd7dc82674185b591354 /m4/libgmp.m4
parent6cb6215cbe65a183e16adf9122280f8a0155ae10 (diff)
downloademacs-33b293b41b2cc64aa085bad9051507922434ceda.tar.gz
Update from Gnulib
This incorporates: 2020-08-06 libgmp: add <gmp/gmp.h> support 2020-08-06 Consider that clang defines __OPTIMIZE__ like GCC does 2020-08-06 Use __builtin_expect with clang everywhere 2020-08-05 Use __builtin_clz{,l,ll} with clang, also on Windows 2020-08-05 Use __builtin_ctz{,l,ll} and __builtin_ffs{,l,ll} with clang 2020-07-31 _GL_CMP: Improve documentation 2020-07-30 alloca, largefile: sync with Autoconf master * lib/c++defs.h, lib/cdefs.h, lib/count-leading-zeros.h: * lib/count-trailing-zeros.h, m4/alloca.m4, m4/gnulib-common.m4: * m4/largefile.m4, m4/libgmp.m4: Copy from Gnulib. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate.
Diffstat (limited to 'm4/libgmp.m4')
-rw-r--r--m4/libgmp.m488
1 files changed, 46 insertions, 42 deletions
diff --git a/m4/libgmp.m4 b/m4/libgmp.m4
index 82c065e2c2c..1025f06a775 100644
--- a/m4/libgmp.m4
+++ b/m4/libgmp.m4
@@ -1,4 +1,4 @@
-# libgmp.m4 serial 4
+# libgmp.m4 serial 5
# Configure the GMP library or a replacement.
dnl Copyright 2020 Free Software Foundation, Inc.
dnl This file is free software; the Free Software Foundation
@@ -18,50 +18,54 @@ AC_DEFUN([gl_LIBGMP],
[AS_HELP_STRING([--without-libgmp],
[do not use the GNU Multiple Precision (GMP) library;
this is the default on systems lacking libgmp.])])
- case "$with_libgmp" in
- no)
- HAVE_LIBGMP=no
- LIBGMP=
- LTLIBGMP=
- ;;
- *)
- dnl Prefer AC_LIB_HAVE_LINKFLAGS if the havelib module is also in use.
- m4_ifdef([gl_HAVE_MODULE_HAVELIB],
- [AC_LIB_HAVE_LINKFLAGS([gmp], [],
- [#include <gmp.h>],
- [static const mp_limb_t x[2] = { 0x73, 0x55 };
- mpz_t tmp;
- mpz_roinit_n (tmp, x, 2);
- ],
- [no])],
- [gl_saved_LIBS=$LIBS
- AC_SEARCH_LIBS([__gmpz_roinit_n], [gmp])
- LIBS=$gl_saved_LIBS
- case $ac_cv_search___gmpz_roinit_n in
- 'none needed')
- HAVE_LIBGMP=yes LIBGMP=;;
- -*)
- HAVE_LIBGMP=yes LIBGMP=$ac_cv_search___gmpz_roinit_n;;
- *)
- HAVE_LIBGMP=no LIBGMP=;;
- esac
- LTLIBGMP=$LIBGMP
- AC_SUBST([HAVE_LIBGMP])
- AC_SUBST([LIBGMP])
- AC_SUBST([LTLIBGMP])])
- if test "$with_libgmp,$HAVE_LIBGMP" = yes,no; then
- AC_MSG_ERROR(
- [GMP not found, although --with-libgmp was specified.m4_ifdef(
- [AC_LIB_HAVE_LINKFLAGS],
- [ Try specifying --with-libgmp-prefix=DIR.])])
- fi
- ;;
- esac
- if test $HAVE_LIBGMP = yes; then
+ HAVE_LIBGMP=no
+ LIBGMP=
+ LTLIBGMP=
+ AS_IF([test "$with_libgmp" != no],
+ [AC_CHECK_HEADERS([gmp.h gmp/gmp.h], [break])
+ dnl Prefer AC_LIB_HAVE_LINKFLAGS if the havelib module is also in use.
+ AS_IF([test "$ac_cv_header_gmp_h" = yes ||
+ test "$ac_cv_header_gmp_gmp_h" = yes],
+ [m4_ifdef([gl_HAVE_MODULE_HAVELIB],
+ [AC_LIB_HAVE_LINKFLAGS([gmp], [],
+ [#if HAVE_GMP_H
+ # include <gmp.h>
+ #else
+ # include <gmp/gmp.h>
+ #endif],
+ [static const mp_limb_t x[2] = { 0x73, 0x55 };
+ mpz_t tmp;
+ mpz_roinit_n (tmp, x, 2);
+ ],
+ [no])],
+ [gl_saved_LIBS=$LIBS
+ AC_SEARCH_LIBS([__gmpz_roinit_n], [gmp])
+ LIBS=$gl_saved_LIBS
+ case $ac_cv_search___gmpz_roinit_n in
+ 'none needed')
+ HAVE_LIBGMP=yes;;
+ -*)
+ HAVE_LIBGMP=yes
+ LIBGMP=$ac_cv_search___gmpz_roinit_n
+ LTLIBGMP=$LIBGMP;;
+ esac
+ AC_SUBST([HAVE_LIBGMP])
+ AC_SUBST([LIBGMP])
+ AC_SUBST([LTLIBGMP])])])
+ if test "$with_libgmp,$HAVE_LIBGMP" = yes,no; then
+ AC_MSG_ERROR(
+ [GMP not found, although --with-libgmp was specified.m4_ifdef(
+ [AC_LIB_HAVE_LINKFLAGS],
+ [ Try specifying --with-libgmp-prefix=DIR.])])
+ fi])
+ if test $HAVE_LIBGMP = yes && test "$ac_cv_header_gmp_h" = yes; then
GMP_H=
else
GMP_H=gmp.h
fi
AC_SUBST([GMP_H])
- AM_CONDITIONAL([GL_GENERATE_GMP_H], [test -n "$GMP_H"])
+ AM_CONDITIONAL([GL_GENERATE_MINI_GMP_H],
+ [test $HAVE_LIBGMP != yes])
+ AM_CONDITIONAL([GL_GENERATE_GMP_GMP_H],
+ [test $HAVE_LIBGMP = yes && test "$ac_cv_header_gmp_h" != yes])
])