summaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2019-07-24 11:28:48 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2019-07-24 12:11:32 -0700
commit50126f2049a03d2910412572c98bafbc26f3db31 (patch)
treef10373da4a557b21d25324fa8b555b338c992ec0 /m4
parentf2cc674ebcac8eb38ce09287fd76e3608cd3b5c3 (diff)
downloademacs-50126f2049a03d2910412572c98bafbc26f3db31.tar.gz
Port double-slash test to z/OS
* admin/merge-gnulib (GNULIB_MODULES): Add double-slash-root. Emacs was already using this Gnulib module indirectly, so this is merely noting that there is now a direct dependency. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate. * src/fileio.c (search_embedded_absfilename): Use DOUBLE_SLASH_IS_DISTINCT_ROOT instead of (WINDOWSNT || CYGWIN). Simplify.
Diffstat (limited to 'm4')
-rw-r--r--m4/gnulib-comp.m42
1 files changed, 2 insertions, 0 deletions
diff --git a/m4/gnulib-comp.m4 b/m4/gnulib-comp.m4
index d6b2009123d..77563edc84d 100644
--- a/m4/gnulib-comp.m4
+++ b/m4/gnulib-comp.m4
@@ -70,6 +70,7 @@ AC_DEFUN([gl_EARLY],
# Code from module dirent:
# Code from module dirfd:
# Code from module dosname:
+ # Code from module double-slash-root:
# Code from module dtoastr:
# Code from module dtotimespec:
# Code from module dup2:
@@ -227,6 +228,7 @@ AC_DEFUN([gl_INIT],
gl_SHA512
gl_CHECK_TYPE_STRUCT_DIRENT_D_TYPE
gl_DIRENT_H
+ gl_DOUBLE_SLASH_ROOT
gl_FUNC_DUP2
if test $HAVE_DUP2 = 0 || test $REPLACE_DUP2 = 1; then
AC_LIBOBJ([dup2])