summaryrefslogtreecommitdiff
path: root/make-dist
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2017-01-03 17:46:40 +0200
committerEli Zaretskii <eliz@gnu.org>2017-01-03 17:46:40 +0200
commit10444dcf77711bf3360f865fcb0d446a83e1bfb5 (patch)
treec5e6586bbae9bb3fdbfd2a7727f9ec9fc0fe8f4a /make-dist
parent134e86b360cab0d0a5cb634b71a4b06ec26c5f1f (diff)
downloademacs-10444dcf77711bf3360f865fcb0d446a83e1bfb5.tar.gz
Generate nt/gnulib.mk from lib/gnulib.mk
This was proposed by Paul Eggert <eggert@cs.ucla.edu>, with the purpose of avoiding manual maintenance of nt/gnulib.mk. * nt/gnulib-modules-to-delete.cfg: New file. * nt/Makefile.in (AM_V_GEN, am__v_GEN_, am__v_GEN_0) (am__v_GEN_1): New variables. (${srcdir}/gnulib.mk): Rules to generate gnulib.mk from lib/gnulib.mk and list of modules in gnulib-modules-to-delete.cfg. * make-dist (nt): Add gnulib-modules-to-delete.cfg to the list of files to link. * configure.ac (GNULIB_MK): Compute the value according to $opsys. * autogen.sh: Create nt/gnulib.mk if it doesn't exist, before running autoreconf. * Makefile.in (gnulib_mk): New variable. ($(srcdir)/nt/gnulib.mk): Rule to produce it. (AUTOMAKE_INPUTS): Use $(gnulib_mk) instead of a literal file name. * .gitignore: Add nt/gnulib.mk. * src/w32.c (acl_errno_valid): Implement it here, as we no longer build the acl-permissions module from Gnulib.
Diffstat (limited to 'make-dist')
-rwxr-xr-xmake-dist2
1 files changed, 1 insertions, 1 deletions
diff --git a/make-dist b/make-dist
index 6513cca3920..41203b20aa7 100755
--- a/make-dist
+++ b/make-dist
@@ -482,7 +482,7 @@ echo "Making links to 'nt'"
(cd nt
ln emacs-x86.manifest emacs-x64.manifest ../${tempdir}/nt
ln [a-z]*.bat [a-z]*.[ch] ../${tempdir}/nt
- ln *.in gnulib.mk ../${tempdir}/nt
+ ln *.in gnulib.mk gnulib-modules-to-delete.cfg ../${tempdir}/nt
ln mingw-cfg.site epaths.nt INSTALL.W64 ../${tempdir}/nt
ln ChangeLog.*[0-9] INSTALL README README.W32 ../${tempdir}/nt)