summaryrefslogtreecommitdiff
path: root/msdos
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2018-05-04 18:12:32 +0300
committerEli Zaretskii <eliz@gnu.org>2018-05-04 18:12:32 +0300
commit91a68b5f61db50344c6a5df497f55370d54a7b15 (patch)
treec907c981342a540ff99618375606c6b9b52e38f9 /msdos
parent7ddcc9ab1a862414b9481af7a587c4add2b60abe (diff)
downloademacs-91a68b5f61db50344c6a5df497f55370d54a7b15.tar.gz
; * msdos/INSTALL: Add info about GCC versions.
Diffstat (limited to 'msdos')
-rw-r--r--msdos/INSTALL15
1 files changed, 12 insertions, 3 deletions
diff --git a/msdos/INSTALL b/msdos/INSTALL
index 3b343f14563..3707f436625 100644
--- a/msdos/INSTALL
+++ b/msdos/INSTALL
@@ -19,6 +19,15 @@ the necessary utilities; search for "MS-DOS". The configuration step
(see below) will test for these utilities and will refuse to continue
if any of them isn't found.
+You should carefully choose the version of GCC you use to build Emacs,
+because recent versions of GCC don't support building Emacs very well.
+The main issue is the debug info: the DJGPP build of Emacs must use
+the COFF debug info. GCC support for COFF debug info was steadily
+deteriorating since GCC 5, and GCC 8.1 officially stopped supporting
+the -gcoff switch, which the Emacs build process needs. We recommend
+using GCC 3.4.X and Binutils 2.26; GDB 7.2 is capable to debug an
+Emacs binary built by this combination.
+
Bootstrapping Emacs or recompiling Lisp files in the `lisp'
subdirectory using the various targets in the lisp/Makefile file
requires additional utilities: `find' (from Findutils), GNU `echo' and
@@ -70,15 +79,15 @@ Running "config msdos" checks for several programs that are required
to configure and build Emacs; if one of those programs is not found,
CONFIG.BAT stops and prints an error message.
-On Windows NT and Windows 2000/XP/Vista/7, running "config msdos"
+On Windows NT and Windows 2000/XP and later, running "config msdos"
might print an error message like "VDM has been already loaded". This
is because those systems have a program called `redir.exe' which is
incompatible with a program by the same name supplied with DJGPP,
which is used by config.bat. To resolve this, move the DJGPP's `bin'
subdirectory to the front of your PATH environment variable.
-Windows Vista/7 has several bugs in its DPMI server related to memory
-allocation: it fails DPMI resize memory block function, and it
+Windows Vista and later has several bugs in its DPMI server related to
+memory allocation: it fails DPMI resize memory block function, and it
arbitrarily limits the default amount of DPMI memory to 32MB. To work
around these bugs, first configure Emacs to use the `malloc' function
from the DJGPP library. To this end, run CONFIG.BAT with the