summaryrefslogtreecommitdiff
path: root/nextstep
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2014-06-24 23:39:03 -0700
committerGlenn Morris <rgm@gnu.org>2014-06-24 23:39:03 -0700
commit002b161a30f2e819a474fdde9d2b36c32e38786c (patch)
treecb3dc94b9c42c885069b27f7ad8db32823f44321 /nextstep
parent4f2a67acd0cb0fcae13219a36fb75fabc85f64c0 (diff)
downloademacs-002b161a30f2e819a474fdde9d2b36c32e38786c.tar.gz
nextstep: trivial Makefile simplification
* nextstep/Makefile.in (${ns_appbindir}): New. (${ns_appbindir}/Emacs): Use order-only prereq to create output dir.
Diffstat (limited to 'nextstep')
-rw-r--r--nextstep/ChangeLog5
-rw-r--r--nextstep/Makefile.in9
2 files changed, 11 insertions, 3 deletions
diff --git a/nextstep/ChangeLog b/nextstep/ChangeLog
index a3d9b3aa283..45a2dbf427c 100644
--- a/nextstep/ChangeLog
+++ b/nextstep/ChangeLog
@@ -1,3 +1,8 @@
+2014-06-25 Glenn Morris <rgm@gnu.org>
+
+ * Makefile.in (${ns_appbindir}): New.
+ (${ns_appbindir}/Emacs): Use order-only prereq to create output dir.
+
2014-06-15 Glenn Morris <rgm@gnu.org>
* Makefile.in (bootstrap-clean): New.
diff --git a/nextstep/Makefile.in b/nextstep/Makefile.in
index 4198fb29453..52f321109b7 100644
--- a/nextstep/Makefile.in
+++ b/nextstep/Makefile.in
@@ -43,9 +43,12 @@ ${ns_check_file} ${ns_appdir}: ${srcdir}/${ns_appsrc} ${ns_appsrc}
( cd ${ns_appdir} ; umask 022; tar xf - )
touch ${ns_appdir}
-${ns_appbindir}/Emacs: ${ns_appdir} ${ns_check_file} ../src/emacs${EXEEXT}
- ${MKDIR_P} ${ns_appbindir}
- cp -f ../src/emacs${EXEEXT} ${ns_appbindir}/Emacs
+${ns_appbindir}:
+ ${MKDIR_P} $@
+
+${ns_appbindir}/Emacs: ${ns_appdir} ${ns_check_file} ../src/emacs${EXEEXT} | \
+ ${ns_appbindir}
+ cp -f ../src/emacs${EXEEXT} $@
.PHONY: all