summaryrefslogtreecommitdiff
path: root/nextstep
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2015-06-22 23:53:22 -0700
committerGlenn Morris <rgm@gnu.org>2015-06-22 23:53:22 -0700
commit371ebe02a67d97a82fcf704a1cbe4251da6d910b (patch)
treeda22814d69cbebdef7c03635270c79a72c2aa8c1 /nextstep
parentd97fbcbedce8f36050af7a55d34c6ed50c99507c (diff)
downloademacs-371ebe02a67d97a82fcf704a1cbe4251da6d910b.tar.gz
Revert 2014-06-25 nextstep/Makefile change.
* nextstep/Makefile.in (${ns_appbindir}): Remove rule. (${ns_appbindir}/Emacs, links): Create ns_appbindir in the rule, not as an order-only prerequisite.
Diffstat (limited to 'nextstep')
-rw-r--r--nextstep/Makefile.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/nextstep/Makefile.in b/nextstep/Makefile.in
index 07e7285924a..2b7933c12ad 100644
--- a/nextstep/Makefile.in
+++ b/nextstep/Makefile.in
@@ -48,11 +48,11 @@ ${ns_check_file} ${ns_appdir}: ${srcdir}/${ns_appsrc} ${ns_appsrc}
( cd ${ns_appdir} ; umask 022; tar xf - )
touch ${ns_appdir}
-${ns_appbindir}:
- ${MKDIR_P} $@
-
-${ns_appbindir}/Emacs: ${ns_appdir} ${ns_check_file} ../src/emacs${EXEEXT} | \
- ${ns_appbindir}
+## Don't create ns_appbindir via an order-only prerequisite, because
+## on GNUstep ns_appbindir and ns_bindir are the same, so
+## the rule for ns_appbindir would conflict with that for ns_appdir.
+${ns_appbindir}/Emacs: ${ns_appdir} ${ns_check_file} ../src/emacs${EXEEXT}
+ ${MKDIR_P} ${ns_appbindir}
cp -f ../src/emacs${EXEEXT} $@
.PHONY: all links
@@ -61,13 +61,14 @@ all: ${ns_appdir} ${ns_appbindir}/Emacs
# create a fake installation pointing back to the source tree
# to run GUI Emacs in-place
-links : ../src/emacs${EXEEXT} | ${ns_appbindir}
+links : ../src/emacs${EXEEXT}
for d in $(shell cd ${srcdir}/${ns_appsrc}; find . -type d); do ${MKDIR_P} ${ns_appdir}/$$d; done
for f in $(shell cd ${srcdir}/${ns_appsrc}; find . -type f); do ln -s $(shell cd ${srcdir}; pwd -P)/${ns_appsrc}/$$f ${ns_appdir}/$$f; done
for d in $(shell cd ${ns_appsrc}; find . -type d); do ${MKDIR_P} ${ns_appdir}/$$d; done
for f in $(shell cd ${ns_appsrc}; find . -type f); do ln -s $(shell cd ${ns_appsrc}; pwd -P)/$$f ${ns_appdir}/$$f; done
ln -s $(top_srcdir_abs)/lisp ${ns_appdir}/Contents/Resources
ln -s $(top_srcdir_abs)/info ${ns_appdir}/Contents/Resources
+ ${MKDIR_P} ${ns_appbindir}
ln -s $(abs_top_builddir)/src/emacs${EXEEXT} ${ns_appbindir}/Emacs
ln -s $(abs_top_builddir)/lib-src ${ns_appbindir}/bin
ln -s $(abs_top_builddir)/lib-src ${ns_appbindir}/libexec