summaryrefslogtreecommitdiff
path: root/nextstep
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-09-16 11:49:00 -0700
committerGlenn Morris <rgm@gnu.org>2012-09-16 11:49:00 -0700
commit83da1b5565d518aa02984bf2f474c56eb61f41ef (patch)
tree5a912cbf397765da7c1a2325b5b2aa7325edb174 /nextstep
parent40d70ecb6d11f87363b500db5665d8b433278687 (diff)
downloademacs-83da1b5565d518aa02984bf2f474c56eb61f41ef.tar.gz
Increase compartmentalization of Nextstep builds rules,
and store Emacs version number in fewer versioned files. * configure.ac (ns_appsrc): Use relative names. (ns_frag): Remove. (Info-gnustep.plist, Emacs.desktop, Info.plist, InfoPlist.strings) (nextstep/Makefile): Generate these nextstep files. (SUBDIR_MAKEFILES): Add nextstep. * Makefile.in (clean, distclean, bootstrap-clean): Add nextstep. * make-dist (nextstep/templates): Add directory. (nextstep/Cocoa/Emacs.base/Contents/Resources/English.lproj): Remove. (nextstep/Cocoa/Emacs.base/Contents) (nextstep/GNUstep/Emacs.base/Resources): Update contents. * .bzrignore: Add some nextstep files. * admin/admin.el (set-version): No more need to set nextstep versions. (set-copyright): Update for moved nextstep files. * nextstep/Makefile.in: New file. * nextstep/templates: New directory. * nextstep/templates/Emacs.desktop.in, nextstep/templates/Info-gnustep.plist.in: * nextstep/templates/Info.plist.in, nextstep/templates/InfoPlist.strings.in: Move here from various Cocoa/, GNUstep/ locations. Let configure set the version number. * nextstep/Cocoa/Emacs.base/Contents/Info.plist: * nextstep/Cocoa/Emacs.base/Contents/Resources/English.lproj/InfoPlist.strings: * nextstep/GNUstep/Emacs.base/Resources/Info-gnustep.plist: * nextstep/GNUstep/Emacs.base/Resources/Emacs.desktop: Move to templates/. * nextstep/Cocoa/Emacs.base/Contents/Resources/English.lproj: Remove directory. * src/Makefile.in (ns_appdir, ns_appbindir, ns_appsrc): Remove variables. (ns_frag): Remove. (ns-app): Move here from ns.mk, and simplify. (clean): Simplify nextstep entry. * src/ns.mk: Remove file.
Diffstat (limited to 'nextstep')
-rw-r--r--nextstep/ChangeLog14
-rw-r--r--nextstep/Makefile.in68
-rw-r--r--nextstep/templates/Emacs.desktop.in (renamed from nextstep/GNUstep/Emacs.base/Resources/Emacs.desktop)2
-rw-r--r--nextstep/templates/Info-gnustep.plist.in (renamed from nextstep/GNUstep/Emacs.base/Resources/Info-gnustep.plist)4
-rw-r--r--nextstep/templates/Info.plist.in (renamed from nextstep/Cocoa/Emacs.base/Contents/Info.plist)4
-rw-r--r--nextstep/templates/InfoPlist.strings.in (renamed from nextstep/Cocoa/Emacs.base/Contents/Resources/English.lproj/InfoPlist.strings)4
6 files changed, 89 insertions, 7 deletions
diff --git a/nextstep/ChangeLog b/nextstep/ChangeLog
index 6451f7a7322..be73bc1f168 100644
--- a/nextstep/ChangeLog
+++ b/nextstep/ChangeLog
@@ -1,3 +1,17 @@
+2012-09-16 Glenn Morris <rgm@gnu.org>
+
+ * Makefile.in: New file.
+ * templates: New directory.
+ * templates/Emacs.desktop.in, templates/Info-gnustep.plist.in:
+ * templates/Info.plist.in, templates/InfoPlist.strings.in:
+ Move here from various Cocoa/, GNUstep/ locations.
+ Let configure set the version number.
+ * Cocoa/Emacs.base/Contents/Info.plist:
+ * Cocoa/Emacs.base/Contents/Resources/English.lproj/InfoPlist.strings:
+ * GNUstep/Emacs.base/Resources/Info-gnustep.plist:
+ * GNUstep/Emacs.base/Resources/Emacs.desktop: Move to templates/.
+ * Cocoa/Emacs.base/Contents/Resources/English.lproj: Remove directory.
+
2012-04-07 Glenn Morris <rgm@gnu.org>
* Cocoa/Emacs.base/Contents/Info.plist:
diff --git a/nextstep/Makefile.in b/nextstep/Makefile.in
new file mode 100644
index 00000000000..8efb2b23043
--- /dev/null
+++ b/nextstep/Makefile.in
@@ -0,0 +1,68 @@
+### nextstep/Makefile for GNU Emacs
+
+## Copyright (C) 2012 Free Software Foundation, Inc.
+
+## This file is part of GNU Emacs.
+
+## GNU Emacs is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, either version 3 of the License, or
+## (at your option) any later version.
+##
+## GNU Emacs is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
+
+### Commentary:
+
+### Code:
+SHELL = /bin/sh
+
+srcdir = @srcdir@
+EXEEXT = @EXEEXT@
+
+@SET_MAKE@
+MKDIR_P = @MKDIR_P@
+
+ns_appdir = @ns_appdir@
+ns_appbindir = @ns_appbindir@
+ns_appsrc = @ns_appsrc@
+
+${ns_appdir}: ${srcdir}/${ns_appsrc} ${ns_appsrc}
+ rm -rf ${ns_appdir}
+ ${MKDIR_P} ${ns_appdir}
+ ( cd ${srcdir}/${ns_appsrc} ; tar cfh - . ) | \
+ ( cd ${ns_appdir} ; umask 022; tar xf - )
+ [ `cd ${srcdir} && /bin/pwd` = `/bin/pwd` ] || \
+ ( cd ${ns_appsrc} ; tar cfh - . ) | \
+ ( cd ${ns_appdir} ; umask 022; tar xf - )
+
+${ns_appbindir}/Emacs: ${ns_appdir} ../src/emacs${EXEEXT}
+ ${MKDIR_P} ${ns_appbindir}
+ cp -f ../src/emacs${EXEEXT} ${ns_appbindir}/Emacs
+
+.PHONY: all
+
+all: ${ns_appdir} ${ns_appbindir}/Emacs
+
+
+.PHONY: clean distclean maintainer-clean
+
+clean:
+ rm -rf ${ns_appdir}
+
+distclean: clean
+ rm -f Makefile
+ rm -f GNUstep/Emacs.base/Resources/Info-gnustep.plist \
+ GNUstep/Emacs.base/Resources/Emacs.desktop \
+ Cocoa/Emacs.base/Contents/Info.plist \
+ Cocoa/Emacs.base/Contents/Resources/English.lproj/InfoPlist.strings
+ [ `cd ${srcdir} && /bin/pwd` = `/bin/pwd` ] || rm -rf ${ns_appsrc}
+
+maintainer-clean: distclean
+
+### Makefile.in ends here
diff --git a/nextstep/GNUstep/Emacs.base/Resources/Emacs.desktop b/nextstep/templates/Emacs.desktop.in
index a36eafaadb0..170f195f270 100644
--- a/nextstep/GNUstep/Emacs.base/Resources/Emacs.desktop
+++ b/nextstep/templates/Emacs.desktop.in
@@ -1,7 +1,7 @@
[Desktop Entry]
Encoding=UTF-8
Type=Application
-Version=24.2.50
+Version=@version@
Categories=GNUstep
Name=Emacs
Comment=GNU Emacs for NeXT/Open/GNUstep and OS X
diff --git a/nextstep/GNUstep/Emacs.base/Resources/Info-gnustep.plist b/nextstep/templates/Info-gnustep.plist.in
index 6cde01b0d05..6da5af489fb 100644
--- a/nextstep/GNUstep/Emacs.base/Resources/Info-gnustep.plist
+++ b/nextstep/templates/Info-gnustep.plist.in
@@ -2,7 +2,7 @@
ApplicationDescription = "GNU Emacs for GNUstep / OS X";
ApplicationIcon = emacs.tiff;
ApplicationName = Emacs;
- ApplicationRelease = "24.2.50";
+ ApplicationRelease = "@version@";
Authors = (
"Adrian Robert (GNUstep)",
"Christophe de Dinechin (MacOS X)",
@@ -13,7 +13,7 @@
);
Copyright = "Copyright (C) 2012 Free Software Foundation, Inc.";
CopyrightDescription = "Released under the GNU General Public License Version 3 or later";
- FullVersionID = "Emacs 24.2.50, NS Windowing";
+ FullVersionID = "Emacs @version@, NS Windowing";
NSExecutable = Emacs;
NSIcon = emacs.tiff;
NSPrincipalClass = NSApplication;
diff --git a/nextstep/Cocoa/Emacs.base/Contents/Info.plist b/nextstep/templates/Info.plist.in
index f5490f613fd..df9708eae71 100644
--- a/nextstep/Cocoa/Emacs.base/Contents/Info.plist
+++ b/nextstep/templates/Info.plist.in
@@ -553,7 +553,7 @@ along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
<key>CFBundleExecutable</key>
<string>Emacs</string>
<key>CFBundleGetInfoString</key>
- <string>Emacs 24.2.50 Copyright (C) 2012 Free Software Foundation, Inc.</string>
+ <string>Emacs @version@ Copyright (C) 2012 Free Software Foundation, Inc.</string>
<key>CFBundleIconFile</key>
<string>Emacs.icns</string>
<key>CFBundleIdentifier</key>
@@ -566,7 +566,7 @@ along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
<string>APPL</string>
<!-- This should be the emacs version number. -->
<key>CFBundleShortVersionString</key>
- <string>24.2.50</string>
+ <string>@version@</string>
<key>CFBundleSignature</key>
<string>EMAx</string>
<!-- This SHOULD be a build number. -->
diff --git a/nextstep/Cocoa/Emacs.base/Contents/Resources/English.lproj/InfoPlist.strings b/nextstep/templates/InfoPlist.strings.in
index 7655c0ca8ec..ce9779c7ac8 100644
--- a/nextstep/Cocoa/Emacs.base/Contents/Resources/English.lproj/InfoPlist.strings
+++ b/nextstep/templates/InfoPlist.strings.in
@@ -1,6 +1,6 @@
/* Localized versions of Info.plist keys */
CFBundleName = "Emacs";
-CFBundleShortVersionString = "Version 24.2.50";
-CFBundleGetInfoString = "Emacs version 24.2.50, NS Windowing";
+CFBundleShortVersionString = "Version @version@";
+CFBundleGetInfoString = "Emacs version @version@, NS Windowing";
NSHumanReadableCopyright = "Copyright (C) 2012 Free Software Foundation, Inc.";