summaryrefslogtreecommitdiff
path: root/nt
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2019-06-24 20:06:34 +0300
committerEli Zaretskii <eliz@gnu.org>2019-06-24 20:06:34 +0300
commit9f5f5ae6386fe1ea9f31bd760d7ffd293d274502 (patch)
treeca27cef4db5fd9e02be339e8a8765b5c8dfe9342 /nt
parent38502cd44d58a92f378b0e6915a5360f32f6f1ab (diff)
downloademacs-9f5f5ae6386fe1ea9f31bd760d7ffd293d274502.tar.gz
Fix MS-Windows build as followup to pdumper executable lookup
* src/w32.c (w32_my_exename): New function. * src/w32.h (w32_my_exename): Add prototype. * src/emacs.c (load_pdump_find_executable) [WINDOWSNT]: Find the actual file name of the program without looking along PATH, by calling w32_my_exename. * nt/mingw-cfg.site (ac_cv_func_canonicalize_file_name) (ac_cv_func_realpath, gl_cv_func_realpath_works): Disable testing. * nt/gnulib-cfg.mk (OMIT_GNULIB_MODULE_canonicalize-lgpl): Set to true.
Diffstat (limited to 'nt')
-rw-r--r--nt/gnulib-cfg.mk1
-rw-r--r--nt/mingw-cfg.site4
2 files changed, 5 insertions, 0 deletions
diff --git a/nt/gnulib-cfg.mk b/nt/gnulib-cfg.mk
index 09cd5822578..91f30ec7149 100644
--- a/nt/gnulib-cfg.mk
+++ b/nt/gnulib-cfg.mk
@@ -62,3 +62,4 @@ OMIT_GNULIB_MODULE_sys_stat = true
OMIT_GNULIB_MODULE_sys_time = true
OMIT_GNULIB_MODULE_sys_types = true
OMIT_GNULIB_MODULE_unistd = true
+OMIT_GNULIB_MODULE_canonicalize-lgpl = true
diff --git a/nt/mingw-cfg.site b/nt/mingw-cfg.site
index e15d14cc392..dfdca3926f9 100644
--- a/nt/mingw-cfg.site
+++ b/nt/mingw-cfg.site
@@ -86,6 +86,10 @@ gl_cv_func_readlink_works=yes
gl_cv_func_symlink_works=yes
ac_cv_func_readlinkat=yes
ac_cv_func_faccessat=yes
+# Avoid compiling Gnulib's canonicalize-lgpl.c, which fails
+ac_cv_func_canonicalize_file_name=yes
+ac_cv_func_realpath="not-needed"
+gl_cv_func_realpath_works="no-but-not-needed-so-yes"
# Implemented in w32.c
ac_cv_func_fcntl=yes
gl_cv_func_fcntl_f_dupfd_cloexec=yes