summaryrefslogtreecommitdiff
path: root/oldXMenu
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-09-03 23:45:44 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2013-09-03 23:45:44 -0700
commit224e313d3bed309a304683c83afe58752cb97e1c (patch)
tree952d4a791e20e1b917b9ca8c3610bfaaecfd64f2 /oldXMenu
parent6d6ed1af817d98f7e78a8be10f5fda14a41e18f6 (diff)
downloademacs-224e313d3bed309a304683c83afe58752cb97e1c.tar.gz
Makefile improvements.
* Makefile.in (lib): Depend on am--refresh, to avoid a race. (src): Remove duplicate dependency on FRC. Invoke just one submake, not two. Avoid the need for 'pwd'. * lwlib/Makefile.in (all): Put this first. Don't use double-colon rules, as they are not portable according to POSIX. Mark as phony. * oldXMenu/Makefile.in (all, tags): Don't use double-colon rules, as they are not portable according to POSIX. Mark as phony. * src/Makefile.in (config.status): Don't use double-colon rules, as they are not portable according to POSIX. Fix shell typo with `; I guess this rule has never been tested? (VCSWITNESS): New macro, to override any environment var.
Diffstat (limited to 'oldXMenu')
-rw-r--r--oldXMenu/ChangeLog6
-rw-r--r--oldXMenu/Makefile.in6
2 files changed, 10 insertions, 2 deletions
diff --git a/oldXMenu/ChangeLog b/oldXMenu/ChangeLog
index 8f2951700e8..21acbe83053 100644
--- a/oldXMenu/ChangeLog
+++ b/oldXMenu/ChangeLog
@@ -1,3 +1,9 @@
+2013-09-04 Paul Eggert <eggert@cs.ucla.edu>
+
+ Makefile improvements.
+ * Makefile.in (all, tags): Don't use double-colon rules, as they
+ are not portable according to POSIX. Mark as phony.
+
2012-12-04 Paul Eggert <eggert@cs.ucla.edu>
Include <config.h> uniformly in oldXMenu sources.
diff --git a/oldXMenu/Makefile.in b/oldXMenu/Makefile.in
index b08e6649cbd..394bfb3ab50 100644
--- a/oldXMenu/Makefile.in
+++ b/oldXMenu/Makefile.in
@@ -85,7 +85,8 @@ OBJS = Activate.o \
SetSel.o \
XDelAssoc.o XLookAssoc.o XCrAssoc.o XDestAssoc.o XMakeAssoc.o
-all:: libXMenu11.a
+all: libXMenu11.a
+.PHONY: all
ALL_CFLAGS=$(C_SWITCH_SYSTEM) $(C_SWITCH_MACHINE) \
$(C_SWITCH_X_SITE) \
@@ -139,5 +140,6 @@ distclean: clean
rm -f Makefile
maintainer-clean: distclean
-tags::
+tags:
$(TAGS) -t *.[ch]
+.PHONY: tags