summaryrefslogtreecommitdiff
path: root/oldXMenu
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2014-06-28 15:57:23 -0700
committerGlenn Morris <rgm@gnu.org>2014-06-28 15:57:23 -0700
commit93160ec3928b5efd654824dfc727d1bbec3c0aec (patch)
treedbca945901d1ff3d2d21e5b20f18ae76d6b134f7 /oldXMenu
parente0d9c3c9a26ba2982595ec2ec4a1167ee7e39ddb (diff)
downloademacs-93160ec3928b5efd654824dfc727d1bbec3c0aec.tar.gz
Use gcc auto-dependency information for lwlib and oldXMenu
* configure.ac (lwlib_deps_frag, oldxmenu_deps_frag): New output files. * make-dist (lwlib, oldXMenu): Distribute *.mk. * lwlib/Makefile.in: Move old dependency information to new file deps.mk. (MKDIR_P, DEPFLAGS, MKDEPDIR, lwlib_deps_frag): New, set by configure. (DEPDIR): New variable. (ALL_CFLAGS): Add DEPFLAGS. (.c.o): Add MKDEPDIR. (clean, mostlyclean): Delete DEPDIR. * lwlib/deps.mk, lwlib/autodeps.mk: New files. * oldXMenu/Makefile.in: Move old dependency information to new file deps.mk. (MKDIR_P, DEPFLAGS, MKDEPDIR, oldxmenu_deps_frag): New, set by configure. (DEPDIR): New variable. (ALL_CFLAGS): Add DEPFLAGS. (.c.o): Add MKDEPDIR. (clean, mostlyclean): Delete DEPDIR. * oldXMenu/deps.mk, oldXMenu/autodeps.mk: New files. * src/deps.mk: Comment update. * .bzrignore: Ignore lwlib/deps, oldXMenu/deps.
Diffstat (limited to 'oldXMenu')
-rw-r--r--oldXMenu/ChangeLog12
-rw-r--r--oldXMenu/Makefile.in47
-rw-r--r--oldXMenu/autodeps.mk5
-rw-r--r--oldXMenu/deps.mk70
4 files changed, 101 insertions, 33 deletions
diff --git a/oldXMenu/ChangeLog b/oldXMenu/ChangeLog
index 74686f64972..2d382be5d71 100644
--- a/oldXMenu/ChangeLog
+++ b/oldXMenu/ChangeLog
@@ -1,3 +1,15 @@
+2014-06-28 Glenn Morris <rgm@gnu.org>
+
+ * Makefile.in: Use gcc auto-dependency information.
+ Move old dependency information to new file deps.mk.
+ (MKDIR_P, DEPFLAGS, MKDEPDIR, oldxmenu_deps_frag):
+ New, set by configure.
+ (DEPDIR): New variable.
+ (ALL_CFLAGS): Add DEPFLAGS.
+ (.c.o): Add MKDEPDIR.
+ (clean, mostlyclean): Delete DEPDIR.
+ * deps.mk, autodeps.mk: New files.
+
2014-06-15 Glenn Morris <rgm@gnu.org>
* Makefile.in (CPPFLAGS): Explicitly set via configure.
diff --git a/oldXMenu/Makefile.in b/oldXMenu/Makefile.in
index 91b313ac627..bfa7d97912a 100644
--- a/oldXMenu/Makefile.in
+++ b/oldXMenu/Makefile.in
@@ -63,6 +63,7 @@ RM = rm -f
RANLIB = @RANLIB@
AR = @AR@
ARFLAGS = @ARFLAGS@
+MKDIR_P = @MKDIR_P@
OBJS = Activate.o \
AddPane.o \
@@ -92,13 +93,20 @@ OBJS = Activate.o \
all: libXMenu11.a
.PHONY: all
+DEPDIR = deps
+## -MMD -MF $(DEPDIR)/$*.d if AUTO_DEPEND; else empty.
+DEPFLAGS = @DEPFLAGS@
+## ${MKDIR_P} ${DEPDIR} (if AUTO_DEPEND); else ':'.
+MKDEPDIR = @MKDEPDIR@
+
ALL_CFLAGS=$(C_SWITCH_SYSTEM) $(C_SWITCH_MACHINE) \
- $(C_SWITCH_X_SITE) \
+ $(C_SWITCH_X_SITE) $(DEPFLAGS) \
$(WARN_CFLAGS) $(WERROR_CFLAGS) ${PROFILING_CFLAGS} \
$(CPPFLAGS) $(CFLAGS) -DEMACS_BITMAP_FILES \
-I../src -I../lib -I${srcdir} -I${srcdir}/../src -I${srcdir}/../lib
.c.o:
+ @$(MKDEPDIR)
$(CC) -c ${ALL_CFLAGS} $<
libXMenu11.a: $(OBJS) $(EXTRA)
@@ -106,42 +114,14 @@ libXMenu11.a: $(OBJS) $(EXTRA)
$(AR) $(ARFLAGS) $@ $(OBJS) $(EXTRA)
$(RANLIB) $@
-Activate.o: Activate.c XMenuInt.h XMenu.h X10.h
-AddPane.o: AddPane.c XMenuInt.h XMenu.h X10.h
-AddSel.o: AddSel.c XMenuInt.h XMenu.h X10.h
-ChgPane.o: ChgPane.c XMenuInt.h XMenu.h X10.h
-ChgSel.o: ChgSel.c XMenuInt.h XMenu.h X10.h
-Create.o: Create.c XMenuInt.h XMenu.h X10.h
-DelPane.o: DelPane.c XMenuInt.h XMenu.h X10.h
-DelSel.o: DelSel.c XMenuInt.h XMenu.h X10.h
-Destroy.o: Destroy.c XMenuInt.h XMenu.h X10.h
-Error.o: Error.c XMenuInt.h XMenu.h X10.h
-EvHand.o: EvHand.c XMenuInt.h XMenu.h X10.h
-FindPane.o: FindPane.c XMenuInt.h XMenu.h X10.h
-FindSel.o: FindSel.c XMenuInt.h XMenu.h X10.h
-InsPane.o: InsPane.c XMenuInt.h XMenu.h X10.h
-InsSel.o: InsSel.c XMenuInt.h XMenu.h X10.h
-Internal.o: Internal.c XMenuInt.h XMenu.h X10.h
-Locate.o: Locate.c XMenuInt.h XMenu.h X10.h
-Post.o: Post.c XMenuInt.h XMenu.h X10.h
-Recomp.o: Recomp.c XMenuInt.h XMenu.h X10.h
-SetAEQ.o: SetAEQ.c XMenuInt.h XMenu.h X10.h
-SetFrz.o: SetFrz.c XMenuInt.h XMenu.h X10.h
-SetPane.o: SetPane.c XMenuInt.h XMenu.h X10.h
-SetSel.o: SetSel.c XMenuInt.h XMenu.h X10.h
-XDelAssoc.o: XDelAssoc.c X10.h
-XLookAssoc.o: XLookAssoc.c X10.h
-XCrAssoc.o: XCrAssoc.c X10.h
-XDestAssoc.o: XDestAssoc.c X10.h
-XMakeAssoc.o: XMakeAssoc.c X10.h
-insque.o: insque.c
+## Insert either autodeps.mk (if AUTO_DEPEND), else deps.mk.
+@oldxmenu_deps_frag@
.PHONY: mostlyclean clean distclean bootstrap-clean maintainer-clean
-mostlyclean:
+clean mostlyclean:
rm -f libXMenu11.a ${OBJS} ${EXTRA}
-
-clean: mostlyclean
+ -rm -rf ${DEPDIR}
bootstrap-clean maintainer-clean distclean: clean
rm -f Makefile
@@ -150,3 +130,4 @@ bootstrap-clean maintainer-clean distclean: clean
tags:
$(TAGS) -t *.[ch]
+### Makefile.in ends here
diff --git a/oldXMenu/autodeps.mk b/oldXMenu/autodeps.mk
new file mode 100644
index 00000000000..f7109295ce2
--- /dev/null
+++ b/oldXMenu/autodeps.mk
@@ -0,0 +1,5 @@
+### autodeps.mk --- lwlib/Makefile fragment for GNU Emacs
+
+## This is inserted in lwlib/Makefile if AUTO_DEPEND=yes.
+
+-include $(ALLOBJS:%.o=${DEPDIR}/%.d)
diff --git a/oldXMenu/deps.mk b/oldXMenu/deps.mk
new file mode 100644
index 00000000000..c5a4966626c
--- /dev/null
+++ b/oldXMenu/deps.mk
@@ -0,0 +1,70 @@
+### deps.mk --- oldXMenu/Makefile fragment for GNU Emacs
+
+## Copyright 1985, 1986, 1987 by the Massachusetts Institute of Technology
+
+## Permission to use, copy, modify, and distribute this
+## software and its documentation for any purpose and without
+## fee is hereby granted, provided that the above copyright
+## notice appear in all copies and that both that copyright
+## notice and this permission notice appear in supporting
+## documentation, and that the name of M.I.T. not be used in
+## advertising or publicity pertaining to distribution of the
+## software without specific, written prior permission.
+## M.I.T. makes no representations about the suitability of
+## this software for any purpose. It is provided "as is"
+## without express or implied warranty.
+
+
+## Copyright (C) 2001-2014 Free Software Foundation, Inc.
+
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, either version 3 of the License, or
+## (at your option) any later version.
+
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+### Commentary:
+
+## This file is inserted in oldXMenu/Makefile if AUTO_DEPEND=no.
+## It defines static dependencies between the various source files.
+
+### Code:
+
+Activate.o: Activate.c XMenuInt.h XMenu.h X10.h
+AddPane.o: AddPane.c XMenuInt.h XMenu.h X10.h
+AddSel.o: AddSel.c XMenuInt.h XMenu.h X10.h
+ChgPane.o: ChgPane.c XMenuInt.h XMenu.h X10.h
+ChgSel.o: ChgSel.c XMenuInt.h XMenu.h X10.h
+Create.o: Create.c XMenuInt.h XMenu.h X10.h
+DelPane.o: DelPane.c XMenuInt.h XMenu.h X10.h
+DelSel.o: DelSel.c XMenuInt.h XMenu.h X10.h
+Destroy.o: Destroy.c XMenuInt.h XMenu.h X10.h
+Error.o: Error.c XMenuInt.h XMenu.h X10.h
+EvHand.o: EvHand.c XMenuInt.h XMenu.h X10.h
+FindPane.o: FindPane.c XMenuInt.h XMenu.h X10.h
+FindSel.o: FindSel.c XMenuInt.h XMenu.h X10.h
+InsPane.o: InsPane.c XMenuInt.h XMenu.h X10.h
+InsSel.o: InsSel.c XMenuInt.h XMenu.h X10.h
+Internal.o: Internal.c XMenuInt.h XMenu.h X10.h
+Locate.o: Locate.c XMenuInt.h XMenu.h X10.h
+Post.o: Post.c XMenuInt.h XMenu.h X10.h
+Recomp.o: Recomp.c XMenuInt.h XMenu.h X10.h
+SetAEQ.o: SetAEQ.c XMenuInt.h XMenu.h X10.h
+SetFrz.o: SetFrz.c XMenuInt.h XMenu.h X10.h
+SetPane.o: SetPane.c XMenuInt.h XMenu.h X10.h
+SetSel.o: SetSel.c XMenuInt.h XMenu.h X10.h
+XDelAssoc.o: XDelAssoc.c X10.h
+XLookAssoc.o: XLookAssoc.c X10.h
+XCrAssoc.o: XCrAssoc.c X10.h
+XDestAssoc.o: XDestAssoc.c X10.h
+XMakeAssoc.o: XMakeAssoc.c X10.h
+insque.o: insque.c
+
+### deps.mk ends here