summaryrefslogtreecommitdiff
path: root/src/bignum.h
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-07-09 16:35:48 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-07-09 16:38:45 -0700
commitc8b6006d82196f9063581e988ea12d6c99c95536 (patch)
tree24ad95ab6523c39190b778f8e63712b6cafaa28b /src/bignum.h
parent501306557c6bb65007f384aa203999d1577d0e99 (diff)
downloademacs-c8b6006d82196f9063581e988ea12d6c99c95536.tar.gz
Use Gnulib libgmp module
Instead of doing GMP by hand, use the Gnulib libgmp module. * .gitignore: Add lib/gmp.h. * admin/merge-gnulib (GNULIB_MODULES): Add libgmp. * configure.ac (GMP_LIB, GMP_OBJ): Remove. Gnulib uses the name LIB_GMP, so all uses changed. All uses of GMP_OBJ removed. (HAVE_GMP): Set this from Gnulib’s variables. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate. * lib/mini-gmp-gnulib.c, lib/mini-gmp.c, lib/mini-gmp.h, m4/libgmp.m4: New files, copied from Gnulib. * src/bignum.h, test/data/emacs-module/mod-test.c: Include gmp.h unconditionally. * src/mini-gmp-emacs.c, src/mini-gmp.c, src/mini-gmp.h: Remove. This moves these files from src to lib, and updates them to the current GMP version. * test/Makefile.in (GMP_H): New macro. ($(test_module)): Use it to decide whether to compile mini-gmp-gnulib.c too.
Diffstat (limited to 'src/bignum.h')
-rw-r--r--src/bignum.h7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/bignum.h b/src/bignum.h
index 4a906c3c0eb..251a19e338a 100644
--- a/src/bignum.h
+++ b/src/bignum.h
@@ -22,12 +22,7 @@ along with GNU Emacs. If not, see <https://www.gnu.org/licenses/>. */
#ifndef BIGNUM_H
#define BIGNUM_H
-#ifdef HAVE_GMP
-# include <gmp.h>
-#else
-# include "mini-gmp.h"
-#endif
-
+#include <gmp.h>
#include "lisp.h"
/* Number of data bits in a limb. */