summaryrefslogtreecommitdiff
path: root/src/decompress.c
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-01-15 20:37:05 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2015-01-15 20:37:44 -0800
commit0adc75af1833cd46aab339ce7f1ca5d6919c70af (patch)
treefb4bc7c0172c31f8313bbde3dabe4ef9bf5fe07e /src/decompress.c
parent255d2a5a53083d676977023e9772d97095c6db46 (diff)
downloademacs-0adc75af1833cd46aab339ce7f1ca5d6919c70af.tar.gz
Give up on -Wsuggest-attribute=const
The attribute doesn't help performance significantly, and the warning seems to be more trouble than it's worth. See the thread at: http://lists.gnu.org/archive/html/emacs-devel/2015-01/msg00361.html * configure.ac (WERROR_CFLAGS): Don't use -Wsuggest-attribute=const. * lib-src/make-docfile.c (write_globals): Remove special hack for Fnext_read_file_uses_dialog_p. * src/decompress.c (Fzlib_available_p): * src/gnutls.c (Fgnutls_available_p): * src/gtkutil.h (xg_uses_old_file_dialog): * src/xdisp.c (Ftool_bar_height): * src/xmenu.c (popup_activated): No longer const, since it's not const on at lest some configurations, and we shouldn't lie to the compiler.
Diffstat (limited to 'src/decompress.c')
-rw-r--r--src/decompress.c3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/decompress.c b/src/decompress.c
index b78dacee207..b14f0a2cd79 100644
--- a/src/decompress.c
+++ b/src/decompress.c
@@ -88,8 +88,7 @@ unwind_decompress (void *ddata)
}
DEFUN ("zlib-available-p", Fzlib_available_p, Szlib_available_p, 0, 0, 0,
- doc: /* Return t if zlib decompression is available in this instance of Emacs. */
- attributes: const)
+ doc: /* Return t if zlib decompression is available in this instance of Emacs. */)
(void)
{
#ifdef WINDOWSNT