summaryrefslogtreecommitdiff
path: root/src/fileio.c
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-03-28 13:58:44 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-03-28 14:08:11 -0700
commit4f41188a6e1eb0ce832bd74907642f30ada344d9 (patch)
treee7416c28af32c57cd06614ea995e10c334ea0aa1 /src/fileio.c
parenta775dca449ca8da2e2619ea608a3849f70fa951e (diff)
downloademacs-4f41188a6e1eb0ce832bd74907642f30ada344d9.tar.gz
Stop using newly-deprecated dosname Gnulib module
Code is supposed to use the filename module now. * admin/merge-gnulib (GNULIB_MODULES): Replace dosname with filename. * lib/dosname.h: Remove this forwarding stub. * lib/gnulib.mk.in, m4/gnulib-comp.m4: Regenerate. * lib-src/emacsclient.c, src/fileio.c: Include filename.h instead of dosname.h.
Diffstat (limited to 'src/fileio.c')
-rw-r--r--src/fileio.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/fileio.c b/src/fileio.c
index ffe79559a3f..978a373d39b 100644
--- a/src/fileio.c
+++ b/src/fileio.c
@@ -96,7 +96,7 @@ along with GNU Emacs. If not, see <https://www.gnu.org/licenses/>. */
#include <acl.h>
#include <allocator.h>
#include <careadlinkat.h>
-#include <dosname.h>
+#include <filename.h>
#include <fsusage.h>
#include <stat-time.h>
#include <tempname.h>