summaryrefslogtreecommitdiff
path: root/src/font.c
diff options
context:
space:
mode:
authorYAMAMOTO Mitsuharu <mituharu@math.s.chiba-u.ac.jp>2019-06-08 14:05:49 +0900
committerYAMAMOTO Mitsuharu <mituharu@math.s.chiba-u.ac.jp>2019-06-08 14:05:49 +0900
commitfaf10bd8eb3272880b774fe220fa9916ed1f00c0 (patch)
treef933e9f012e0c96effefb02daa31ead9acc22aed /src/font.c
parent88c49ac31898e7b2c29338ca55cae292c450f7be (diff)
downloademacs-faf10bd8eb3272880b774fe220fa9916ed1f00c0.tar.gz
Support X core font driver on cairo (Bug#28236)
* configure.ac (HAVE_X_WINDOWS): Add xfont.o to FONT_OBJ if HAVE_CAIRO. * doc/lispref/frames.texi (Font and Color Parameters): Mention X core font driver with Cairo drawing. * src/font.c (syms_of_font) [HAVE_X_WINDOWS && USE_CAIRO]: Call syms_of_xfont. * src/xfns.c (x_create_tip_frame) [USE_CAIRO]: Register xfont_driver. * src/xterm.c (x_cr_gc_clip) [USE_CAIRO]: New function extracted from x_begin_cr_clip. (x_begin_cr_clip) [USE_CAIRO]: Use it. (xlib_surface_key, saved_drawable_key) [USE_CAIRO]: New variables. (x_cr_destroy_xlib_surface, x_try_cr_xlib_drawable) (x_end_cr_xlib_drawable) [USE_CAIRO]: New functions. (x_draw_composite_glyph_string_foreground) (x_draw_glyph_string_foreground) [USE_CAIRO]: Get Xlib surface when drawing text with X core fonts into bitmap surfaces. Add fallback code for drawing into outline surfaces.
Diffstat (limited to 'src/font.c')
-rw-r--r--src/font.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/font.c b/src/font.c
index 6ab4923c3d2..5705758b99f 100644
--- a/src/font.c
+++ b/src/font.c
@@ -5497,10 +5497,10 @@ cause Xft crashes. Only has an effect in Xft builds. */);
#ifdef HAVE_FREETYPE
syms_of_ftfont ();
#ifdef HAVE_X_WINDOWS
+ syms_of_xfont ();
#ifdef USE_CAIRO
syms_of_ftcrfont ();
#else
- syms_of_xfont ();
syms_of_ftxfont ();
#ifdef HAVE_XFT
syms_of_xftfont ();