summaryrefslogtreecommitdiff
path: root/src/lastfile.c
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-08-31 19:37:22 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-08-31 19:37:22 -0700
commit1564080f0b24551765d7068b9fc02f6e5a78fea3 (patch)
treec710c96b8aef1bdb16ae9287b5fd775695a8547c /src/lastfile.c
parent56f9f0ab54fd752773d8bb371a4032e43c9c224c (diff)
downloademacs-1564080f0b24551765d7068b9fc02f6e5a78fea3.tar.gz
Clean up extern decls a bit.
* configure.ac (WERROR_CFLAGS): Don't disable -Wnested-externs. While we're at it, don't disable -Wlogical-op either. * src/bytecode.c: Include blockinput.h and keyboard.h rather than rolling their APIs by hand. * src/emacs.c: Include regex.h and rely on its and lisp.h's API rather than rolling them by hand. * src/lastfile.c: Include lisp.h, to check this file's API. * src/lisp.h (lisp_eval_depth, my_edata, my_endbss, my_endbss_static): New decls. * src/regex.h (re_max_failures): New decl. * src/unexcw.c, src/unexmacosx.c, src/unexw32.c: Rely on lisp.h's API rather than rolling it by hand. * src/vm-limit.c (__after_morecore_hook, __morecore, real_morecore): Declare at top level, to pacify GCC -Wnested-externs.
Diffstat (limited to 'src/lastfile.c')
-rw-r--r--src/lastfile.c2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/lastfile.c b/src/lastfile.c
index a900e9541c8..e7136e069d0 100644
--- a/src/lastfile.c
+++ b/src/lastfile.c
@@ -36,6 +36,8 @@ along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>. */
#include <config.h>
+#include <lisp.h>
+
char my_edata[] = "End of Emacs initialized data";
/* Help unexec locate the end of the .bss area used by Emacs (which