summaryrefslogtreecommitdiff
path: root/src/w32heap.h
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2014-06-03 10:28:07 +0300
committerEli Zaretskii <eliz@gnu.org>2014-06-03 10:28:07 +0300
commit89b362029282eff2b709e3a64e8e4ec3bc673676 (patch)
tree8e76bb48f6720e0be50d0fa33054081c5be5d631 /src/w32heap.h
parent0031c9530d24fb25d8bdcadaf7457b7dee51da0c (diff)
downloademacs-89b362029282eff2b709e3a64e8e4ec3bc673676.tar.gz
Define the size of dumped data for MS-Windows locally on w32heap.c.
configure.ac (C_HEAP_SWITCH): Remove. src/w32heap.c (DUMPED_HEAP_SIZE): Move from w32heap.h. Don't use HEAPSIZE; instead, define separate values for the 32- and 64-bit builds. src/Makefile.in (C_HEAP_SWITCH): Remove. (ALL_CFLAGS): Don't use $(C_HEAP_SWITCH).
Diffstat (limited to 'src/w32heap.h')
-rw-r--r--src/w32heap.h4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/w32heap.h b/src/w32heap.h
index 18b6c85c2de..787fe9ade5f 100644
--- a/src/w32heap.h
+++ b/src/w32heap.h
@@ -28,10 +28,6 @@ along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
* Heap related stuff.
*/
-#define DUMPED_HEAP_SIZE (HEAPSIZE*1024*1024)
-
-extern unsigned char dumped_data[];
-
extern unsigned char *get_data_start (void);
extern unsigned char *get_data_end (void);
extern size_t reserved_heap_size;