summaryrefslogtreecommitdiff
path: root/src/w32inevt.c
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2013-06-03 21:06:09 +0200
committerMichael Albinus <michael.albinus@gmx.de>2013-06-03 21:06:09 +0200
commit7f203aa1fde2bc9ec43aa05a939525cdab149832 (patch)
tree43e175dbe784faa04b4f3b284b1c62a89c26822a /src/w32inevt.c
parent55a87246bae97514b6e927b9401b2b79592b8b91 (diff)
downloademacs-7f203aa1fde2bc9ec43aa05a939525cdab149832.tar.gz
* configure.ac (HAVE_GFILENOTIFY): Do not change $LIBS.
(GFILENOTIFY_CFLAGS, GFILENOTIFY_LIBS): Substitute. * nt/config.nt: Add HAVE_GFILENOTIFY, HAVE_W32NOTIFY and USE_FILE_NOTIFY. * src/Makefile.in (GFILENOTIFY_CFLAGS, GFILENOTIFY_LIBS): New variables. (ALL_CFLAGS): Add $(GFILENOTIFY_CFLAGS). (LIBES): Add $(GFILENOTIFY_LIBS). * src/w32inevt.c (handle_file_notifications): Add dummy implementation for !HAVE_W32NOTIFY. * src/w32term.c: Wrap code with HAVE_W32NOTIFY.
Diffstat (limited to 'src/w32inevt.c')
-rw-r--r--src/w32inevt.c8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/w32inevt.c b/src/w32inevt.c
index 3c38cf806e8..88a3f9739cd 100644
--- a/src/w32inevt.c
+++ b/src/w32inevt.c
@@ -577,6 +577,7 @@ maybe_generate_resize_event (void)
0, 0, 0);
}
+#if HAVE_W32NOTIFY
static int
handle_file_notifications (struct input_event *hold_quit)
{
@@ -644,6 +645,13 @@ handle_file_notifications (struct input_event *hold_quit)
leave_crit ();
return nevents;
}
+#else /* !HAVE_W32NOTIFY */
+static int
+handle_file_notifications (struct input_event *hold_quit)
+{
+ return 0;
+}
+#endif /* !HAVE_W32NOTIFY */
/* Here's an overview of how Emacs input works in non-GUI sessions on
MS-Windows. (For description of the GUI input, see the commentary