summaryrefslogtreecommitdiff
path: root/test/README
diff options
context:
space:
mode:
authorNoam Postavsky <npostavs@gmail.com>2018-06-06 21:25:52 -0400
committerNoam Postavsky <npostavs@gmail.com>2018-06-12 07:26:06 -0400
commit5bdc344780faabbc91b7e55306b2071dffb44fa2 (patch)
tree675856e8329dbd3bb77afd86e166869bbbcc7ce6 /test/README
parentb6b793bd77cb8be0a2d2745262e53037dc6798a0 (diff)
downloademacs-5bdc344780faabbc91b7e55306b2071dffb44fa2.tar.gz
; Reduce quoting for SELECTOR in 'make -C test' (Bug#31744)
Before: make -C test SELECTOR='\"foo\"' make -C test SELECTOR='(quote (tag :some-tag))' After: make -C test SELECTOR='"foo"' make -C test SELECTOR='(tag :some-tag)' * test/Makefile.in: Use single quotes around the command line call to ert, this means the user doesn't have to backslash escape double quotes when writing lisp strings for the selector. Also wrap the SELECTOR value in (quote ...) so the user won't have to type it in (and not get tempted to use the '... reader syntax form which would now fail to work due to using single quotes around the whole shell arg). * test/README: Update instructions accordingly.
Diffstat (limited to 'test/README')
-rw-r--r--test/README5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/README b/test/README
index c1dde2e0d01..e473248c9e0 100644
--- a/test/README
+++ b/test/README
@@ -42,7 +42,10 @@ except the tests tagged as expensive.
If your test file contains the tests "test-foo", "test2-foo" and
"test-foo-remote", and you want to run only the former two tests, you
-could use a selector regexp: "make <filename> SELECTOR='\"foo$$\"'".
+could use a selector regexp (note that the "$" needs to be doubled to
+protect against "make" variable expansion):
+
+ make <filename> SELECTOR='"foo$$"'
Note that although the test files are always compiled (unless they set
no-byte-compile), the source files will be run by default, to give