summaryrefslogtreecommitdiff
path: root/test/data
diff options
context:
space:
mode:
authorPhilipp Stephani <phst@google.com>2019-04-24 19:35:36 +0200
committerPhilipp Stephani <phst@google.com>2019-04-24 23:27:43 +0200
commit4eb7f9ef595c10df1ea78518b2f0410a0e79ec70 (patch)
treeb5721d7166a2b7d7285879bcb06b3a122182f6ff /test/data
parent553220fca670ec13180e0763bc9338fbf8ed4b30 (diff)
downloademacs-4eb7f9ef595c10df1ea78518b2f0410a0e79ec70.tar.gz
Unbreak build when building without GMP support.
Add support for a new preprocessor macro EMACS_MODULE_HAVE_MPZ_T to emacs-module.h. If this macro is defined, assume that mpz_t is already defined and don’t include gmp.h. Don’t document the new macro for now, as it’s unclear whether we want to support this in modules outside the Emacs tree. * src/emacs-module.h.in: Allow user to prevent inclusion of gmp.h. * src/emacs-module.c: Use mini-gmp if GMP is unavailable. Don’t include gmp.h. * src/lisp.h: Don’t require gmp.h. It’s not needed for lisp.h. * test/Makefile.in (GMP_LIB, GMP_OBJ): New variables. ($(test_module)): Use them. * test/data/emacs-module/mod-test.c: Use mini-gmp if GMP is unavailable.
Diffstat (limited to 'test/data')
-rw-r--r--test/data/emacs-module/mod-test.c9
1 files changed, 7 insertions, 2 deletions
diff --git a/test/data/emacs-module/mod-test.c b/test/data/emacs-module/mod-test.c
index 8ac08f71534..b7007bd80ff 100644
--- a/test/data/emacs-module/mod-test.c
+++ b/test/data/emacs-module/mod-test.c
@@ -27,11 +27,16 @@ along with GNU Emacs. If not, see <https://www.gnu.org/licenses/>. */
#include <string.h>
#include <time.h>
+#ifdef HAVE_GMP
+#include <gmp.h>
+#else
+#include "mini-gmp.h"
+#define EMACS_MODULE_HAVE_MPZ_T
+#endif
+
#define EMACS_MODULE_GMP
#include <emacs-module.h>
-#include <gmp.h>
-
#include "timespec.h"
int plugin_is_GPL_compatible;