summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2022-07-05 23:25:44 -0500
committerPaul Eggert <eggert@cs.ucla.edu>2022-07-05 23:27:17 -0500
commit54e0b14a6981a317210493f0fead1e2c5b6508ea (patch)
tree4d6f3c5b45a31ff56f76a6d4c9184024962968af /test
parente482379a65e99cb61aba86876587b499eeeef007 (diff)
downloademacs-54e0b14a6981a317210493f0fead1e2c5b6508ea.tar.gz
Adjust better to Autoconf quoting style change
* admin/gitmerge.el (gitmerge-emacs-version): * admin/nt/dist-build/build-zips.sh (ACTUAL_VERSION): * admin/quick-install-emacs (VERSION): * lisp/cedet/ede/emacs.el (ede-emacs-version): Adjust to change in configure.ac’s Autoconf quoting style. * etc/srecode/ede-autoconf.srt: * test/lisp/progmodes/autoconf-tests.el: (autoconf-tests-current-defun-function-define) (autoconf-tests-current-defun-function-subst): Use better Autoconf quoting. * make-dist (version): Simplify.
Diffstat (limited to 'test')
-rw-r--r--test/lisp/progmodes/autoconf-tests.el8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/lisp/progmodes/autoconf-tests.el b/test/lisp/progmodes/autoconf-tests.el
index e383b4bb6c4..7c609f3c2a7 100644
--- a/test/lisp/progmodes/autoconf-tests.el
+++ b/test/lisp/progmodes/autoconf-tests.el
@@ -31,18 +31,18 @@
(ert-deftest autoconf-tests-current-defun-function-define ()
(with-temp-buffer
- (insert "AC_DEFINE(HAVE_RSVG, 1, [Define to 1 if using librsvg.])")
+ (insert "AC_DEFINE([HAVE_RSVG], [1], [Define to 1 if using librsvg.])")
(goto-char (point-min))
(should-not (autoconf-current-defun-function))
- (forward-char 10)
+ (forward-char 11)
(should (equal (autoconf-current-defun-function) "HAVE_RSVG"))))
(ert-deftest autoconf-tests-current-defun-function-subst ()
(with-temp-buffer
- (insert "AC_SUBST(srcdir)")
+ (insert "AC_SUBST([srcdir])")
(goto-char (point-min))
(should-not (autoconf-current-defun-function))
- (forward-char 9)
+ (forward-char 10)
(should (equal (autoconf-current-defun-function) "srcdir"))))
(ert-deftest autoconf-tests-autoconf-mode-comment-syntax ()