summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorTed Zlatanov <tzz@lifelogs.com>2021-01-21 19:34:03 +0000
committerTed Zlatanov <tzz@lifelogs.com>2021-01-21 21:39:48 +0000
commit90bd6d8ba66bde8d9626f3dd05d14372734e6ce5 (patch)
tree295f713fcb4c1d867e89e10cbb198b2a394c054d /test
parentb41b4add7bc2485fadc6ff3a890efbd1307b2351 (diff)
downloademacs-90bd6d8ba66bde8d9626f3dd05d14372734e6ce5.tar.gz
* test/infra/gitlab-ci.yml: Copy newer files to image to build less often.
Diffstat (limited to 'test')
-rw-r--r--test/infra/gitlab-ci.yml9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/infra/gitlab-ci.yml b/test/infra/gitlab-ci.yml
index e5413ad9380..2f71d12bdb3 100644
--- a/test/infra/gitlab-ci.yml
+++ b/test/infra/gitlab-ci.yml
@@ -100,10 +100,13 @@ default:
script:
- docker pull ${CI_REGISTRY_IMAGE}:${target}-${BUILD_TAG}
# TODO: with make -j4 several of the tests were failing, for example shadowfile-tests, but passed without it
- - docker run -i --rm -e EMACS_EMBA_CI=${EMACS_EMBA_CI} ${CI_REGISTRY_IMAGE}:${target}-${BUILD_TAG} make ${make_params}
+ - 'export PWD=$(pwd)'
+ - 'docker run -i --rm -e EMACS_EMBA_CI=${EMACS_EMBA_CI} --volumes-from $(docker ps -q -f "label=com.gitlab.gitlab-runner.job.id=${CI_JOB_ID}"):ro ${CI_REGISTRY_IMAGE}:${target}-${BUILD_TAG} /bin/bash -c "git fetch ${PWD} HEAD && echo checking out these updated files && git diff --name-only FETCH_HEAD && ( git diff --name-only FETCH_HEAD | xargs git checkout -f FETCH_HEAD ) && make -j4 && make ${make_params}"'
.build-template:
rules:
+ - if: '$CI_PIPELINE_SOURCE == "web"'
+ when: always
- changes:
- "**/Makefile.in"
- .gitlab-ci.yml
@@ -111,11 +114,9 @@ default:
- autogen.sh
- configure.ac
- lib/*.{h,c}
- - lisp/**/*.el
+ - lisp/emacs-lisp/*.el
- src/*.{h,c}
- test/infra/*
- - test/lisp/**/*.el
- - test/src/*.el
- changes:
# gfilemonitor, kqueue
- src/gfilenotify.c