summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore5
-rw-r--r--debian/changelog5
-rw-r--r--debian/control41
-rw-r--r--debian/dirs1
-rw-r--r--debian/links1
-rwxr-xr-xdebian/postinst7
-rwxr-xr-xdebian/prerm7
-rwxr-xr-xdebian/rules24
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/patch-header8
-rw-r--r--lisp/startup.el6
11 files changed, 105 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 890e63a4318..a6f7a8beeb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -23,6 +23,11 @@
# in Git 1.8.2 (March 2013).
+# Debian packaging
+config.guess
+config.sub
+debian/emacs-snapshot/
+
# Personal customization.
.dir-locals-2.el
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000000..1ff032c6133
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+emacs-snapshot (28~git20200722.1) UNRELEASED; urgency=medium
+
+ * Package git snapshot.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 03 Jul 2020 22:45:19 -0700
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000000..acdb68168bb
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,41 @@
+Source: emacs-snapshot
+Section: editors
+Priority: optional
+Maintainer: Sean Whitton <spwhitton@spwhitton.name>
+Build-Depends:
+ autoconf,
+ automake,
+ bsd-mailx | mailx,
+ dbus-x11,
+ debhelper-compat (= 12),
+ gnupg-agent,
+ imagemagick,
+ libacl1-dev,
+ libasound2-dev,
+ libdbus-1-dev,
+ libgif-dev,
+ libgnutls28-dev,
+ libgpm-dev,
+ libjpeg-dev,
+ liblockfile-dev,
+ libm17n-dev,
+ libmagick++-6.q16-dev,
+ libncurses5-dev,
+ libotf-dev,
+ libpng-dev,
+ librsvg2-dev,
+ libselinux1-dev,
+ libsystemd-dev,
+ libtiff-dev,
+ libxaw7-dev,
+ libxml2-dev,
+ procps,
+ sharutils,
+ texinfo,
+ xaw3dg-dev,
+ zlib1g-dev,
+
+Package: emacs-snapshot
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Emacs git snapshot
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 00000000000..057f2009f6c
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+/usr/share/emacs-snapshot/site-lisp/elpa
diff --git a/debian/links b/debian/links
new file mode 100644
index 00000000000..ac7e4afc766
--- /dev/null
+++ b/debian/links
@@ -0,0 +1 @@
+/usr/local/bin/emacs /usr/bin/emacs-snapshot
diff --git a/debian/postinst b/debian/postinst
new file mode 100755
index 00000000000..6e1fde4934b
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+
+/usr/lib/emacsen-common/emacs-install emacs-snapshot
+
+#DEBHELPER#
diff --git a/debian/prerm b/debian/prerm
new file mode 100755
index 00000000000..e72305bba57
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+
+/usr/lib/emacsen-common/emacs-remove emacs-snapshot
+
+#DEBHELPER#
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000000..e3ec6e366ab
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_update_autotools_config:
+ cp -a /usr/share/misc/config.guess /usr/share/misc/config.sub .
+
+override_dh_autoreconf:
+ ./autogen.sh
+
+override_dh_auto_configure:
+ ./configure --prefix=/usr/local --with-x-toolkit=lucid
+
+override_dh_usrlocal:
+
+override_dh_shlibdeps:
+ dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+
+# ensure .elc files are newer than their counterparts to prevent
+# recursive load errors with jka-compr.el (see #803462)
+override_dh_strip_nondeterminism:
+
+override_dh_auto_test:
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000000..89ae9db8f88
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/source/patch-header b/debian/source/patch-header
new file mode 100644
index 00000000000..69436f69f1c
--- /dev/null
+++ b/debian/source/patch-header
@@ -0,0 +1,8 @@
+The Debian packaging of emacs-snapshot is maintained in git, using the
+merging workflow described in dgit-maint-merge(7). There isn't a
+patch queue that can be represented as a quilt series.
+
+A detailed breakdown of the changes is available from their canonical
+representation - git commits in the packaging repository.
+
+A single combined diff, containing all the changes, follows.
diff --git a/lisp/startup.el b/lisp/startup.el
index bff10003f84..d679a96e779 100644
--- a/lisp/startup.el
+++ b/lisp/startup.el
@@ -1233,6 +1233,9 @@ please check its value")
;; If any package directory exists, initialize the package system.
(and user-init-file
package-enable-at-startup
+ (require 'package)
+ (add-to-list 'package-directory-list
+ "/usr/share/emacs-snapshot/site-lisp/elpa")
(not (bound-and-true-p package--activated))
(catch 'package-dir-found
(let (dirs)
@@ -1357,7 +1360,8 @@ please check its value")
;; be loaded from site-run-file and wants to test if -q was given
;; should check init-file-user instead, since that is already set.
;; See cus-edit.el for an example.
- (if site-run-file
+ (when site-run-file
+ (load "/etc/emacs/site-start.d/00debian.el")
;; Sites should not disable the startup screen.
;; Only individuals should disable the startup screen.
(let ((inhibit-startup-screen inhibit-startup-screen))