summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac6
-rw-r--r--lib/Makefile.in6
2 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 888b4151487..bf768441fe3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5878,6 +5878,12 @@ if test $AUTO_DEPEND = yes; then
AS_MKDIR_P([$dir/deps])
done
fi
+if $gl_gnulib_enabled_scratch_buffer; then
+ AS_MKDIR_P([lib/malloc])
+ if test $AUTO_DEPEND = yes; then
+ AS_MKDIR_P([lib/deps/malloc])
+ fi
+fi
AC_OUTPUT
diff --git a/lib/Makefile.in b/lib/Makefile.in
index a280b7a3311..e6b1ae6a9ab 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -67,7 +67,7 @@ endif
DEPDIR = deps
ifeq ($(AUTO_DEPEND),yes)
- DEPFLAGS = -MMD -MF $(DEPDIR)/$(*F).d -MP
+ DEPFLAGS = -MMD -MF $(DEPDIR)/$*.d -MP
-include $(ALLOBJS:%.o=$(DEPDIR)/%.d)
else
DEPFLAGS =
@@ -118,7 +118,7 @@ TAGS: $(ETAGS) $(tagsfiles)
.PHONY: $(ETAGS) tags
clean:
- rm -f ./*.[ao] ./*-t \#* $(DEPDIR)/*
+ rm -f ./*.[ao] ./*/*.o ./*-t \#* $(DEPDIR)/*.d $(DEPDIR)/*/*.d
mostlyclean: clean
rm -f $(filter-out %-t,$(MOSTLYCLEANFILES))
distclean bootstrap-clean: mostlyclean
@@ -127,7 +127,7 @@ distclean bootstrap-clean: mostlyclean
maintainer-clean: distclean
rm -f TAGS gnulib.mk
extraclean: distclean
- -rmdir sys 2>/dev/null
+ -rmdir malloc sys 2>/dev/null
.PHONY: mostlyclean clean distclean bootstrap-clean maintainer-clean