summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--leim/ChangeLog7
-rw-r--r--leim/Makefile.in2
-rw-r--r--lib-src/ChangeLog5
-rw-r--r--lib-src/Makefile.in2
-rw-r--r--lisp/ChangeLog5
-rw-r--r--lisp/Makefile.in2
6 files changed, 20 insertions, 3 deletions
diff --git a/leim/ChangeLog b/leim/ChangeLog
index 4bda9a64335..a8dbca29526 100644
--- a/leim/ChangeLog
+++ b/leim/ChangeLog
@@ -1,3 +1,10 @@
+2015-02-23 Pete Williamson <petewil0@googlemail.com> (tiny change)
+
+ Use ${EXEEXT} more uniformly in makefiles
+ When porting Emacs to run on NaCl, we need to make sure that we always
+ call it with the proper extension (.nexe in this case) during the build.
+ * Makefile.in (EMACS): Append ${EXEEXT}.
+
2015-01-04 Paul Eggert <eggert@cs.ucla.edu>
Less 'make' chatter for leim
diff --git a/leim/Makefile.in b/leim/Makefile.in
index 573acf7678c..2ec03db49b7 100644
--- a/leim/Makefile.in
+++ b/leim/Makefile.in
@@ -47,7 +47,7 @@ unexport EMACSDATA EMACSDOC EMACSPATH
# Which Emacs to use to convert TIT files to Emacs Lisp files,
# and generate the file leim-list.el.
-EMACS = ../src/emacs
+EMACS = ../src/emacs${EXEEXT}
# How to run Emacs.
# Prevent any setting of EMACSLOADPATH in user environment causing problems.
diff --git a/lib-src/ChangeLog b/lib-src/ChangeLog
index 4ac9638102f..f161dbc038f 100644
--- a/lib-src/ChangeLog
+++ b/lib-src/ChangeLog
@@ -1,3 +1,8 @@
+2015-02-23 Paul Eggert <eggert@cs.ucla.edu>
+
+ Use ${EXEEXT} more uniformly in makefiles
+ * Makefile.in (EMACS): Append ${EXEEXT}.
+
2015-02-20 Paul Eggert <eggert@cs.ucla.edu>
Simplify binary I/O configuration
diff --git a/lib-src/Makefile.in b/lib-src/Makefile.in
index d2705e7b5dc..6b5d379e38b 100644
--- a/lib-src/Makefile.in
+++ b/lib-src/Makefile.in
@@ -21,7 +21,7 @@
SHELL = @SHELL@
# Following ../lisp/Makefile.in.
-EMACS = ../src/emacs
+EMACS = ../src/emacs${EXEEXT}
EMACSOPT = -batch --no-site-file --no-site-lisp
# ==================== Things `configure' will edit ====================
diff --git a/lisp/ChangeLog b/lisp/ChangeLog
index 2c22ed24bb6..7b6b48b1018 100644
--- a/lisp/ChangeLog
+++ b/lisp/ChangeLog
@@ -1,3 +1,8 @@
+2015-02-23 Paul Eggert <eggert@cs.ucla.edu>
+
+ Use ${EXEEXT} more uniformly in makefiles
+ * Makefile.in (EMACS): Append ${EXEEXT}.
+
2015-02-23 Sam Steingold <sds@gnu.org>
* files.el (recover-session): Handle `auto-save-list-file-prefix'
diff --git a/lisp/Makefile.in b/lisp/Makefile.in
index e5cfc6326e1..22d5ddcf12f 100644
--- a/lisp/Makefile.in
+++ b/lisp/Makefile.in
@@ -47,7 +47,7 @@ am__v_GEN_1 =
# We never change directory before running Emacs, so a relative file
# name is fine, and makes life easier. If we need to change
# directory, we can use emacs --chdir.
-EMACS = ../src/emacs
+EMACS = ../src/emacs${EXEEXT}
# Command line flags for Emacs.