summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog3
-rw-r--r--INSTALL5
-rw-r--r--etc/ChangeLog5
-rw-r--r--etc/NEWS3
-rw-r--r--lib-src/ChangeLog10
-rw-r--r--lib-src/Makefile.in40
-rw-r--r--lwlib/ChangeLog7
-rw-r--r--lwlib/Makefile.in10
-rw-r--r--oldXMenu/ChangeLog7
-rw-r--r--oldXMenu/Makefile.in10
-rw-r--r--src/ChangeLog6
-rw-r--r--src/Makefile.in19
12 files changed, 107 insertions, 18 deletions
diff --git a/ChangeLog b/ChangeLog
index d3039bed1c7..7bf2a572f98 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
2014-09-01 Paul Eggert <eggert@cs.ucla.edu>
+ --enable-silent-warnings now suppresses more chatter.
+ * INSTALL: Document this.
+
Clean up extern decls a bit.
* configure.ac (WERROR_CFLAGS): Don't disable -Wnested-externs.
While we're at it, don't disable -Wlogical-op either.
diff --git a/INSTALL b/INSTALL
index 94fa6ba653b..4bda46cfbc0 100644
--- a/INSTALL
+++ b/INSTALL
@@ -328,6 +328,11 @@ and is useful with GNU-compatible compilers. On a recent GNU system
there should be no warnings; on older and on non-GNU systems the
generated warnings may still be useful.
+Use --enable-silent-rules to cause 'make' to chatter less. This is
+helpful when combined with options like --enable-gcc-warnings that
+generate long shell-command lines. 'make V=0' also suppresses the
+chatter.
+
Use --enable-link-time-optimization to enable link-time optimizer. If
you're using GNU compiler, this feature is supported since version 4.5.0.
If `configure' can determine number of online CPUS on your system, final
diff --git a/etc/ChangeLog b/etc/ChangeLog
index 60f9edbc6ce..4c8b5b1767e 100644
--- a/etc/ChangeLog
+++ b/etc/ChangeLog
@@ -1,3 +1,8 @@
+2014-09-01 Paul Eggert <eggert@cs.ucla.edu>
+
+ --enable-silent-warnings now suppresses more chatter.
+ * NEWS: Document this.
+
2014-08-29 Leo Liu <sdl.web@gmail.com>
* NEWS: Mention (:append FUN) to minibuffer-with-setup-hook.
diff --git a/etc/NEWS b/etc/NEWS
index 7b2ee186e95..100214f1108 100644
--- a/etc/NEWS
+++ b/etc/NEWS
@@ -40,6 +40,9 @@ or by sticking with Emacs 24.4.
** The configure option `--with-pkg-config-prog' has been removed.
Use './configure PKG_CONFIG=/full/name/of/pkg-config' if you need to.
+** The configure option '--enable-silent-rules' and the command
+'make V=0' now do a better job of suppressing chatter.
+
* Startup Changes in Emacs 24.5
diff --git a/lib-src/ChangeLog b/lib-src/ChangeLog
index bf4d500921b..b96fb192027 100644
--- a/lib-src/ChangeLog
+++ b/lib-src/ChangeLog
@@ -1,5 +1,15 @@
2014-09-01 Paul Eggert <eggert@cs.ucla.edu>
+ --enable-silent-warnings now suppresses more chatter.
+ * Makefile.in (AM_DEFAULT_VERBOSITY, AM_V_CC, am__v_CC_)
+ (am__v_CC_0, am__v_CC_1, AM_V_CCLD, am__v_CCLD_, am__v_CCLD_0)
+ (am__v_CCLD_1): New macros, taken from Automake.
+ (regex.o, etags${EXEEXT}, ctags${EXEEXT}, ebrowse${EXEEXT})
+ (profile${EXEEXT}, make-docfile${EXEEXT}, movemail${EXEEXT})
+ (pop.o, emacsclient${EXEEXT}, emacsclientw${EXEEXT})
+ (emacsclientw${EXEEXT}, ntlib.o, hexl${EXEEXT})
+ (update-game-score${EXEEXT}): Use them.
+
* etags.c (emacs_strchr, emacs_strrchr): Remove.
All uses replaced by strchr and strrchr, which are on all
target platforms now.
diff --git a/lib-src/Makefile.in b/lib-src/Makefile.in
index 7eb13f667ec..fe101047dea 100644
--- a/lib-src/Makefile.in
+++ b/lib-src/Makefile.in
@@ -45,6 +45,19 @@ UPDATE_MANIFEST = @UPDATE_MANIFEST@
# Program name transformation.
TRANSFORM = @program_transform_name@
+# 'make' verbosity.
+AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
+
+AM_V_CC = $(am__v_CC_@AM_V@)
+am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
+am__v_CC_0 = @echo " CC " $@;
+am__v_CC_1 =
+
+AM_V_CCLD = $(am__v_CCLD_@AM_V@)
+am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
+am__v_CCLD_0 = @echo " CCLD " $@;
+am__v_CCLD_1 =
+
# ==================== Where To Install Things ====================
# Location to install Emacs.app under GNUstep / Mac OS X.
@@ -311,7 +324,7 @@ TAGS: etags${EXEEXT}
$(MAKE) -C ../lib libgnu.a
regex.o: $(srcdir)/../src/regex.c $(srcdir)/../src/regex.h $(config_h)
- ${CC} -c ${CPP_CFLAGS} $<
+ $(AM_V_CC)$(CC) -c $(CPP_CFLAGS) $<
etags_deps = ${srcdir}/etags.c regex.o $(NTLIB) $(config_h)
@@ -319,41 +332,41 @@ etags_cflags = -DEMACS_NAME="\"GNU Emacs\"" -DVERSION="\"${version}\"" -o $@
etags_libs = regex.o $(LOADLIBES) $(NTLIB)
etags${EXEEXT}: ${etags_deps}
- $(CC) ${ALL_CFLAGS} $(etags_cflags) $< $(etags_libs)
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $(etags_cflags) $< $(etags_libs)
## ctags.c is distinct from etags.c so that parallel makes do not write two
## etags.o files on top of each other.
## FIXME?
## Can't we use a wrapper that calls 'etags --ctags'?
ctags${EXEEXT}: ${srcdir}/ctags.c ${etags_deps}
- $(CC) ${ALL_CFLAGS} $(etags_cflags) $< $(etags_libs)
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $(etags_cflags) $< $(etags_libs)
ebrowse${EXEEXT}: ${srcdir}/ebrowse.c ${srcdir}/../lib/min-max.h $(NTLIB) \
$(config_h)
- $(CC) ${ALL_CFLAGS} -DVERSION="\"${version}\"" \
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} -DVERSION="\"${version}\"" \
$< $(LOADLIBES) $(NTLIB) -o $@
profile${EXEEXT}: ${srcdir}/profile.c $(NTLIB) $(config_h)
- $(CC) ${ALL_CFLAGS} $< \
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $< \
$(LOADLIBES) $(NTLIB) $(LIB_CLOCK_GETTIME) -o $@
make-docfile${EXEEXT}: ${srcdir}/make-docfile.c $(NTLIB) $(config_h)
- $(CC) ${ALL_CFLAGS} $< $(LOADLIBES) $(NTLIB) -o $@
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $< $(LOADLIBES) $(NTLIB) -o $@
movemail${EXEEXT}: ${srcdir}/movemail.c pop.o $(NTLIB) $(config_h)
- $(CC) ${ALL_CFLAGS} ${MOVE_FLAGS} $< pop.o \
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} ${MOVE_FLAGS} $< pop.o \
$(LOADLIBES) $(NTLIB) $(LIBS_MOVE) -o $@
pop.o: ${srcdir}/pop.c ${srcdir}/pop.h ${srcdir}/../lib/min-max.h $(config_h)
- $(CC) -c ${CPP_CFLAGS} ${MOVE_FLAGS} $<
+ $(AM_V_CC)$(CC) -c ${CPP_CFLAGS} ${MOVE_FLAGS} $<
emacsclient${EXEEXT}: ${srcdir}/emacsclient.c $(NTLIB) $(config_h)
- $(CC) ${ALL_CFLAGS} $< \
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $< \
-DVERSION="\"${version}\"" $(NTLIB) $(LOADLIBES) $(LIB_FDATASYNC) \
$(LIB_WSOCK32) $(LIBS_ECLIENT) -o $@
emacsclientw${EXEEXT}: ${srcdir}/emacsclient.c $(NTLIB) $(CLIENTRES) $(config_h)
- $(CC) ${ALL_CFLAGS} $(CLIENTRES) -mwindows $< \
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $(CLIENTRES) -mwindows $< \
-DVERSION="\"${version}\"" $(LOADLIBES) $(LIB_FDATASYNC) \
$(LIB_WSOCK32) $(LIBS_ECLIENT) -o $@
@@ -365,13 +378,14 @@ NTDEPS = $(NTINC)/ms-w32.h $(NTINC)/sys/stat.h $(NTINC)/inttypes.h \
# The dependency on $(NTDEPS) is a trick intended to cause recompile of
# programs on MinGW whenever some private header in nt/inc is modified.
ntlib.o: ${srcdir}/ntlib.c ${srcdir}/ntlib.h $(NTDEPS)
- $(CC) -c ${CPP_CFLAGS} $<
+ $(AM_V_CC)$(CC) -c ${CPP_CFLAGS} $<
hexl${EXEEXT}: ${srcdir}/hexl.c $(NTLIB) $(config_h)
- $(CC) ${ALL_CFLAGS} $< $(LOADLIBES) -o $@
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} $< $(LOADLIBES) -o $@
update-game-score${EXEEXT}: ${srcdir}/update-game-score.c $(NTLIB) $(config_h)
- $(CC) ${ALL_CFLAGS} -DHAVE_SHARED_GAME_DIR="\"$(gamedir)\"" \
+ $(AM_V_CCLD)$(CC) ${ALL_CFLAGS} \
+ -DHAVE_SHARED_GAME_DIR="\"$(gamedir)\"" \
$< $(LOADLIBES) $(NTLIB) -o $@
emacsclient.res: $(NTINC)/../emacsclient.rc
diff --git a/lwlib/ChangeLog b/lwlib/ChangeLog
index 11ee10edac2..c832dd39927 100644
--- a/lwlib/ChangeLog
+++ b/lwlib/ChangeLog
@@ -1,3 +1,10 @@
+2014-09-01 Paul Eggert <eggert@cs.ucla.edu>
+
+ --enable-silent-warnings now suppresses more chatter.
+ * Makefile.in (AM_DEFAULT_VERBOSITY, AM_V_CC, am__v_CC_)
+ (am__v_CC_0, am__v_CC_1): New macros, taken from Automake.
+ (.c.o): Use them.
+
2014-07-15 Dmitry Antipov <dmantipov@yandex.ru>
* lwlib.h (toplevel): Use unsigned int for LWLIB_ID.
diff --git a/lwlib/Makefile.in b/lwlib/Makefile.in
index 516b3286951..b01e69c4392 100644
--- a/lwlib/Makefile.in
+++ b/lwlib/Makefile.in
@@ -51,6 +51,14 @@ TOOLKIT_OBJS = $(@X_TOOLKIT_TYPE@_OBJS)
OBJS = lwlib.o $(TOOLKIT_OBJS) lwlib-utils.o
+# 'make' verbosity.
+AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
+
+AM_V_CC = $(am__v_CC_@AM_V@)
+am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
+am__v_CC_0 = @echo " CC " $@;
+am__v_CC_1 =
+
DEPDIR = deps
## -MMD -MF $(DEPDIR)/$*.d if AUTO_DEPEND; else empty.
DEPFLAGS = @DEPFLAGS@
@@ -73,7 +81,7 @@ all: liblw.a
.c.o:
@$(MKDEPDIR)
- $(CC) -c $(CPPFLAGS) $(ALL_CFLAGS) $<
+ $(AM_V_CC)$(CC) -c $(CPPFLAGS) $(ALL_CFLAGS) $<
liblw.a: $(OBJS)
rm -f $@
diff --git a/oldXMenu/ChangeLog b/oldXMenu/ChangeLog
index 1d98a544d25..e19c695c217 100644
--- a/oldXMenu/ChangeLog
+++ b/oldXMenu/ChangeLog
@@ -1,3 +1,10 @@
+2014-09-01 Paul Eggert <eggert@cs.ucla.edu>
+
+ --enable-silent-warnings now suppresses more chatter.
+ * Makefile.in (AM_DEFAULT_VERBOSITY, AM_V_CC, am__v_CC_)
+ (am__v_CC_0, am__v_CC_1): New macros, taken from Automake.
+ (.c.o): Use them.
+
2014-07-12 Dmitry Antipov <dmantipov@yandex.ru>
* XMenuInt.h (XDeleteAssoc): Remove duplicated prototype to
diff --git a/oldXMenu/Makefile.in b/oldXMenu/Makefile.in
index bfa7d97912a..230828157e8 100644
--- a/oldXMenu/Makefile.in
+++ b/oldXMenu/Makefile.in
@@ -93,6 +93,14 @@ OBJS = Activate.o \
all: libXMenu11.a
.PHONY: all
+# 'make' verbosity.
+AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
+
+AM_V_CC = $(am__v_CC_@AM_V@)
+am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
+am__v_CC_0 = @echo " CC " $@;
+am__v_CC_1 =
+
DEPDIR = deps
## -MMD -MF $(DEPDIR)/$*.d if AUTO_DEPEND; else empty.
DEPFLAGS = @DEPFLAGS@
@@ -107,7 +115,7 @@ ALL_CFLAGS=$(C_SWITCH_SYSTEM) $(C_SWITCH_MACHINE) \
.c.o:
@$(MKDEPDIR)
- $(CC) -c ${ALL_CFLAGS} $<
+ $(AM_V_CC)$(CC) -c ${ALL_CFLAGS} $<
libXMenu11.a: $(OBJS) $(EXTRA)
$(RM) $@
diff --git a/src/ChangeLog b/src/ChangeLog
index 0bf0842690b..35f0ba03f21 100644
--- a/src/ChangeLog
+++ b/src/ChangeLog
@@ -1,5 +1,11 @@
2014-09-01 Paul Eggert <eggert@cs.ucla.edu>
+ --enable-silent-warnings now suppresses more chatter.
+ * Makefile.in (AM_DEFAULT_VERBOSITY, AM_V_CC, am__v_CC_)
+ (am__v_CC_0, am__v_CC_1, AM_V_CCLD, am__v_CCLD_, am__v_CCLD_0)
+ (am__v_CCLD_1): New macros, taken from Automake.
+ (.c.o, .m.o, temacs$(EXEEXT)): Use them.
+
Clean up extern decls a bit.
* bytecode.c: Include blockinput.h and keyboard.h rather
than rolling their APIs by hand.
diff --git a/src/Makefile.in b/src/Makefile.in
index 3f1192fe3ff..3fe1b1c83c2 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -304,6 +304,19 @@ UNEXEC_OBJ = @UNEXEC_OBJ@
CANNOT_DUMP=@CANNOT_DUMP@
+# 'make' verbosity.
+AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
+
+AM_V_CC = $(am__v_CC_@AM_V@)
+am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
+am__v_CC_0 = @echo " CC " $@;
+am__v_CC_1 =
+
+AM_V_CCLD = $(am__v_CCLD_@AM_V@)
+am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
+am__v_CCLD_0 = @echo " CCLD " $@;
+am__v_CCLD_1 =
+
DEPDIR=deps
## -MMD -MF $(DEPDIR)/$*.d if AUTO_DEPEND; else empty.
DEPFLAGS=@DEPFLAGS@
@@ -334,10 +347,10 @@ ALL_OBJC_CFLAGS=$(ALL_CFLAGS) $(GNU_OBJC_CFLAGS)
.SUFFIXES: .m
.c.o:
@$(MKDEPDIR)
- $(CC) -c $(CPPFLAGS) $(ALL_CFLAGS) $(PROFILING_CFLAGS) $<
+ $(AM_V_CC)$(CC) -c $(CPPFLAGS) $(ALL_CFLAGS) $(PROFILING_CFLAGS) $<
.m.o:
@$(MKDEPDIR)
- $(CC) -c $(CPPFLAGS) $(ALL_OBJC_CFLAGS) $(PROFILING_CFLAGS) $<
+ $(AM_V_CC)$(CC) -c $(CPPFLAGS) $(ALL_OBJC_CFLAGS) $(PROFILING_CFLAGS) $<
## lastfile must follow all files whose initialized data areas should
## be dumped as pure by dump-emacs.
@@ -491,7 +504,7 @@ $(lib)/libgnu.a: $(config_h)
## to start if Vinstallation_directory has the wrong value.
temacs$(EXEEXT): $(LIBXMENU) $(ALLOBJS) \
$(lib)/libgnu.a $(EMACSRES)
- $(CC) $(ALL_CFLAGS) $(TEMACS_LDFLAGS) $(LDFLAGS) \
+ $(AM_V_CCLD)$(CC) $(ALL_CFLAGS) $(TEMACS_LDFLAGS) $(LDFLAGS) \
-o temacs $(ALLOBJS) $(lib)/libgnu.a $(W32_RES_LINK) $(LIBES)
$(MKDIR_P) $(etc)
test "$(CANNOT_DUMP)" = "yes" || \