summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000000..ecfccf56312
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_update_autotools_config:
+ cp -a /usr/share/misc/config.guess /usr/share/misc/config.sub .
+
+override_dh_autoreconf:
+ ./autogen.sh
+
+override_dh_auto_configure:
+ ./configure --prefix=/opt/emacs-snapshot --with-x-toolkit=lucid
+
+override_dh_shlibdeps:
+ dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+
+# ensure .elc files are newer than their counterparts to prevent
+# recursive load errors with jka-compr.el (see #803462)
+override_dh_strip_nondeterminism:
+
+override_dh_auto_test: